Commit f398aa6a authored by Eric Anholt's avatar Eric Anholt

mesa: Only require independent blending for GLES 3.2.

We've been requiring this since GLES 3.0 was introduced, but the GLES 3.2
spec is the one that has "Supporting blending on a per-draw-buffer basis"
in the new features.  V3D 3.3 would require lowering blending to shader
code to implement independent blending.
Reviewed-by: Tapani Pälli's avatarTapani Pälli <tapani.palli@intel.com>
parent 60d8fe92
......@@ -516,7 +516,6 @@ compute_version_es2(const struct gl_extensions *extensions,
extensions->ARB_texture_float &&
extensions->ARB_texture_rg &&
extensions->ARB_depth_buffer_float &&
extensions->EXT_draw_buffers2 &&
/* extensions->ARB_framebuffer_object && */
extensions->EXT_framebuffer_sRGB &&
extensions->EXT_packed_float &&
......@@ -546,6 +545,7 @@ compute_version_es2(const struct gl_extensions *extensions,
extensions->ARB_gpu_shader5 &&
extensions->EXT_shader_integer_mix);
const bool ver_3_2 = (ver_3_1 &&
extensions->EXT_draw_buffers2 &&
extensions->KHR_blend_equation_advanced &&
extensions->KHR_robustness &&
extensions->KHR_texture_compression_astc_ldr &&
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment