meson: require GLib >= 2.44

This matches the Autotools change in
5ae45631. Even though the Autotools
build was subsequently dropped, the use of g_autofree remains.
parent 225d5f96
......@@ -41,9 +41,9 @@ configinc = include_directories('.')
gnome = import('gnome')
cc = meson.get_compiler('c')
base_deps = [ dependency('glib-2.0', version: '>= 2.34.0'),
dependency('gio-2.0', version: '>= 2.34.0'),
dependency('gio-unix-2.0', version: '>= 2.34.0') ]
base_deps = [ dependency('glib-2.0', version: '>= 2.44.0'),
dependency('gio-2.0', version: '>= 2.44.0'),
dependency('gio-unix-2.0', version: '>= 2.44.0') ]
libm = cc.find_library('m', required: false)
if libm.found()
base_deps += [ libm ]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment