Commit 23fa2533 authored by Bernd Zeimetz's avatar Bernd Zeimetz Committed by Jussi Kukkonen

Use pkg-config to check for gpsd, require 2.91.

We need 2.91 as we rely on gps_poll being non-blocking.
parent 5e39671e
......@@ -209,19 +209,18 @@ AC_ARG_ENABLE(gpsd,
enable_gpsd=auto)
if test "x$enable_gpsd" != "xno"; then
AC_CHECK_LIB(gps, gps_open,[libgps=yes] )
PKG_CHECK_MODULES(GPSD, [libgps >= 2.91], have_gpsd="yes", have_gpsd="no")
if test "x$have_gpsd" = "xyes"; then
PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gpsd"
GPSD_LIBS="-lgps"
else
NO_BUILD_PROVIDERS="$NO_BUILD_PROVIDERS gpsd"
fi
else
else
have_gpsd=no
fi
if test "x$enable_gpsd" = "xyes" -a "x$have_gpsd" != "xyes"; then
AC_MSG_ERROR([Couldn't find gpsd dependencies.])
AC_MSG_ERROR([Couldn't find gpsd dependencies - libgps >= 2.90.])
fi
AC_SUBST(GPSD_LIBS)
AC_SUBST(GPSD_CFLAGS)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment