Commit 4fc3aa6e authored by Seungha Yang's avatar Seungha Yang 🐑

hls: Check nettle version to ensure AES128 support

AES128 support was added since nettle version 3.0

../subprojects/gst-plugins-bad/ext/hls/gsthlsdemux.h:110:10: error: field ‘ctx’ has incomplete type
   struct CBC_CTX (struct aes128_ctx, AES_BLOCK_SIZE) aes_ctx;
parent bdf9a762
......@@ -21,7 +21,7 @@ if hls_option.disabled()
endif
if ['auto', 'nettle'].contains(hls_crypto)
hls_crypto_dep = dependency('nettle', required : false)
hls_crypto_dep = dependency('nettle', version : '>= 3.0', required : false)
if hls_crypto_dep.found()
hls_cargs += ['-DHAVE_NETTLE']
endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment