Commit e39dc0f5 authored by Adam Jackson's avatar Adam Jackson 🥃

present: Require presentproto 1.2

The PresentOptionSuboptimal support code is not optional (once you've
enabled building Present at all), so require a protocol package version
that defines what we need.

Fixes: xorg/xserver#821
parent 9acff309
......@@ -754,7 +754,7 @@ DAMAGEPROTO="damageproto >= 1.1"
XCMISCPROTO="xcmiscproto >= 1.2.0"
BIGREQSPROTO="bigreqsproto >= 1.1.0"
XTRANS="xtrans >= 1.3.5"
PRESENTPROTO="presentproto >= 1.1"
PRESENTPROTO="presentproto >= 1.2"
dnl List of libraries that require a specific version
LIBAPPLEWM="applewm >= 1.4"
......
......@@ -22,7 +22,7 @@ libxserver_present = static_library('libxserver_present',
include_directories: inc,
dependencies: [
common_dep,
dependency('presentproto', version: '>= 1.1')
dependency('presentproto', version: '>= 1.2')
],
c_args: '-DHAVE_XORG_CONFIG_H'
)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment