Commit c42b09b4 authored by Kristian Høgsberg's avatar Kristian Høgsberg
Browse files

configure.ac: Fix publican version check

This sure is ugly - we feed output of publican -v into bc to compare
against minimum required version, 2.8.  That's bad enough, but when
publican suddenly report 3.0.0, bc starts complaining...

Use sed to filter out 3.0 from the 'version=3.0.0' output from publican
instead.  Seem a little more robust, but it's just a matter of time before
something else breaks this flaky setup.

Hey, publican, how about shipping .pc files?
parent 9d296fc7
...@@ -101,7 +101,7 @@ if test "x$enable_documentation" = "xyes"; then ...@@ -101,7 +101,7 @@ if test "x$enable_documentation" = "xyes"; then
AC_PATH_PROG(PUBLICAN, publican) AC_PATH_PROG(PUBLICAN, publican)
if test "x$PUBLICAN" != "x"; then if test "x$PUBLICAN" != "x"; then
PUBLICAN_VERSION=`$PUBLICAN -v | cut -d'=' -f2` PUBLICAN_VERSION=[`$PUBLICAN -v | sed -e 's/version=\([0-9]*\.[0-9]*\).*/\1/'`]
if test [ 1 -eq `echo "${PUBLICAN_VERSION} < 2.8" | bc` ]; then if test [ 1 -eq `echo "${PUBLICAN_VERSION} < 2.8" | bc` ]; then
AC_MSG_ERROR([Publican version is not supported. Install publican >= 2.8 or disable the documentation using --disable-documentation]) AC_MSG_ERROR([Publican version is not supported. Install publican >= 2.8 or disable the documentation using --disable-documentation])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment