Commit d1acea57 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller 🐠

REQUIREMENTS: update a little

People actually look at that it seems.
parent 69ec922c
GStreamer uses a *large* array of tools and libraries, most of which are GStreamer uses a *large* array of tools and libraries, most of which are
optional. We have attempted to make sure that any code that depends on optional. We have attempted to make sure that any code that depends on
optional libraries doesn't get built unless you have those libraries. If optional libraries doesn't get built unless you have those libraries. If
you find this not to be the case, please, let us know by filing a bug you find this not to be the case, please, let us know by filing a bug
report at http://bugzilla.gnome.org/. report at http://bugzilla.gnome.org/.
On Debian/Ubuntu, the easiest way to install most build requirements is:
sudo apt-get build-dep gst-plugins-good1.0
Required tools: Required tools:
=============== ===============
An extra set of tools is required if you wish to build GStreamer out of An extra set of tools is required if you wish to build GStreamer
CVS (using autogen.sh): from git (using autogen.sh):
autoconf 2.52 or better autoconf >= 2.68 https://www.gnu.org/software/autoconf/
automake 1.5 automake >= 1.11 https://www.gnu.org/software/automake/
gettext 0.11.5 gettext >= 0.17 https://www.gnu.org/software/gettext/
libtool v1.4 or better libtool >= 2.2.6 https://www.gnu.org/software/libtool/
pkgconfig 0.9.0 or better (http://www.freedesktop.org/software/pkgconfig/) pkgconfig >= 0.9.0 https://www.freedesktop.org/software/pkgconfig/
Required libraries: Required libraries:
=================== ===================
Package: GStreamer Package: GStreamer
Version: 0.10.11.2 Version: 1.x (same 1.x version as this package)
Recommended: 0.10.latest Recommended: Latest 1.x
URL: http://gstreamer.freedesktop.org/ URL: http://gstreamer.freedesktop.org/
DebianPackage: libgstreamer0.10-dev DebianPackage: libgstreamer1.0-dev
Notes: The required version is updated frequently, so the version Notes: The required version is updated frequently, so the version
listed in this file is often wrong. If you are compiling from CVS, listed in this file is often out of date. If you are compiling
the required version is often the latest GStreamer CVS. from git master, you will usually need GStreamer core and
gst-plugins-base from git master as well.
Package: GStreamer Base Plugins
Version: 0.10.11.2 Package: GStreamer Base Plugins
Recommended: 0.10.latest Version: 1.x (same 1.x version as this package)
URL: http://gstreamer.freedesktop.org/ Recommended: Latest 1.x
DebianPackage: libgstreamer-plugins-base0.10-dev URL: http://gstreamer.freedesktop.org/
Notes: The required version is updated frequently, so the version DebianPackage: libgstreamer-plugins-base1.0-dev
listed in this file is often wrong. If you are compiling from CVS, Notes: The required version is updated frequently, so the version
the required version is often the latest GStreamer Base Plugins CVS. listed in this file is often out of date. If you are compiling
from git master, you will usually need GStreamer core and
gst-plugins-base from git master as well.
Optional libraries: Optional libraries:
=================== ===================
This file lists supporting libraries for which gst-plugins contains plugins, This file lists supporting libraries for which gst-plugins-good contains
as well as their minimum version. You can find the corresponding plugins in plugins, as well as their minimum required version. You can find the
ext/(library) corresponding plugins in ext/(library)
Package: Orc Package: Orc
Version: >= 0.4.5 Version: >= 0.4.17
Recommended: 0.4.latest Recommended: Latest 0.4.x
URL: http://code.entropywave.com/orc URL: http://gstreamer.freedesktop.org/data/src/orc/
DebianPackage: liborc-0.4-dev DebianPackage: liborc-0.4-dev
Notes: Used by many plugins for accelerating processing Notes: Used by many plugins for accelerating SIMD processing using
run-time generated assembly. Not a hard requirement, but
Package: GTK+ highly recommended. Packagers, please hard-depend on liborc.
Version: >= 2.0 The git repository is http://cgit.freedesktop.org/gstreamer/orc/
Recommended: >= 2.2 (all versions on entropywave.com are outdated)
URL: http://www.gtk.org/
DebianPackage: libgtk2.0-dev Package: gdk-pixbuf Library
Plugins: gdkpixbuf (gdkpixbufdec, gdkpixbufscale) Version: >= 2.8.0
Notes: Also required by several examples. Plugin require >= 2.2. Recommended: Latest 2.x
URL: http://www.gtk.org/
Package: Check DebianPackage: libgdk-pixbuf2.0-dev
DebianPackage: check Plugins: gdkpixbuf (gdkpixbufdec, gdkpixbufoverlay)
URL: http://check.sourceforge.net/ Notes: This library does not depend on Gtk+ or Gdk or any window system
Package: Xlib Package: GTK+
Plugins: ximagesrc, v4l2 Version: >= 3.0
DebianPackage: libx11-dev libxv-dev libxt-dev Recommended: Latest 3.x
URL: http://www.gtk.org/
Package: AALib DebianPackage: libgtk-3-dev
Plugins: aasink Plugins: None
URL: http://aa-project.sourceforge.net/aalib/ Notes: Only needed by some of the examples, not by any plugins.
Package: LibXML Package: Xlib
Version: >= 2.4.9 Plugins: ximagesrc
Plugins: annodex (cmmlenc, cmmldec) DebianPackage: libx11-dev libxv-dev libxt-dev
URL: http://xmlsoft.org/
Package: AALib
Package: Cairo Plugins: aasink
Version: >= 1.0 URL: http://aa-project.sourceforge.net/aalib/
Plugins: cairo (cairotextoverlay, cairotimeoverlay)
URL: http://cairographics.org/ Package: Cairo
Version: >= 1.10
Package: CDIO DebianPackage: libcairo2-dev
Version: >= 0.71 Plugins: cairo (cairooverlay)
Plugins: cdio (cdiocddasrc) URL: http://cairographics.org/
URL: http://www.gnu.org/software/libcdio/
Package: FLAC
Package: FLAC Version: >= 1.1.4
Version: == 1.1.2 DebianPackage: libflac-dev
Plugins: flac (flacenc, flacdec) Plugins: flac (flacenc, flacdec)
URL: http://flac.sourceforge.net/ URL: http://flac.sourceforge.net/
Package: HAL Package: gudev
Version: >= 0.5.6 Version: >= 147
Plugins: halelements (halaudiosink, halaudiosrc) DebianPackage: libgudev-1.0-dev
URL: http://hal.freedesktop.org/ Plugins: v4l2 (v4l2src)
URL: http://www.freedesktop.org/software/systemd/
Package: IJG JPEG library Notes: This dependency is entirely optional, the video4linux plugin
Plugins: jpeg (jpegenc, jpegdec, smokeenc, smokedec) will work just fine without it. gudev is only required for
URL: http://www.ijg.org/ the device probing and monitoring functionality to detect
video4linux devices appearing/disappearing at run-time.
Package: LADSPA
Plugins: ladspa Package: JPEG library
URL: http://www.ladspa.org/ Plugins: jpeg (jpegenc, jpegdec, smokeenc, smokedec)
DebianPackage: libjpeg-dev
Package: Libcaca URL: http://www.libjpeg-turbo.org/
Plugins: cacasink or http://www.ijg.org/ for the IJG version
URL: http://libcaca.zoy.org/
Package: Libcaca
Package: Libdv Plugins: cacasink
Version: >= 0.100 DebianPackage: libcaca-dev
Plugins: dv (dvdec) URL: http://libcaca.zoy.org/
URL: http://libdv.sourceforge.net/
Package: Libdv
Package: Libpng Version: >= 0.100
Version: >= 1.2 DebianPackage: libdv4-dev
Plugins: png (pngenc, pngdec) Plugins: dv (dvdec)
URL: http://www.libpng.org/pub/png/libpng.html URL: http://libdv.sourceforge.net/
Package: libraw1394 Package: Libpng
Plugins: dv1394 Version: >= 1.2
URL: http://www.linux1394.org/ DebianPackage: libpng12-dev
Plugins: png (pngenc, pngdec)
Package: libiec61883 URL: http://www.libpng.org/pub/png/libpng.html
Plugins: dv1394
URL: http://www.linux1394.org/ Package: libraw1394
Plugins: dv1394
Package: libshout URL: http://www.linux1394.org/
Version: >= 2.0
URL: http://www.icecast.org/ Package: libshout
Version: >= 2.0
Package: speex DebianPackage: libshout3-dev
Version: >= 1.0.4 or >= 1.1.5 plugins: shout2 (shout2send)
Plugins: speex (speexenc, speexdec) URL: http://www.icecast.org/
URL: http://www.speex.org/
Package: speex
Package: taglib Version: >= 1.1.6
Version: >= 1.4 Plugins: speex (speexenc, speexdec)
DebianPackage: libtag1-dev URL: http://www.speex.org/
URL: http://developer.kde.org/~wheeler/taglib.html
Package: taglib
Package: zlib Version: >= 1.5
Plugins: id3demux DebianPackage: libtag1-dev
URL: http://www.zlib.net/ Plugins: taglib (id3v2mux)
URL: http://taglib.github.io/
Package: zlib
DebianPackage: zlib1g-dev
Plugins: isomp4 (qtdemux), matroska (matroskademux)
URL: http://www.zlib.net/
Optional (debian) packages: Optional (debian) packages:
=========================== ===========================
gtk-doc-tools 1.6 -- needed to build documentation gtk-doc-tools >= 1.12 -- needed to build documentation
python-xml -- needed to build plugin documentation python-xml -- needed to build plugin documentation
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment