Commit b7d55c18 authored by Michael Smith's avatar Michael Smith
Browse files

sys/osxaudio/Makefile.am: osxaudio plugin now requires AudioUnit framework, so link against that.

Original commit message from CVS:
* sys/osxaudio/Makefile.am:
osxaudio plugin now requires AudioUnit framework, so link against that.
Clean up tabs v spaces while I'm there.
parent 89060e86
2009-01-13 Michael Smith <msmith@songbirdnest.com>
* sys/osxaudio/Makefile.am:
osxaudio plugin now requires AudioUnit framework, so link against that.
Clean up tabs v spaces while I'm there.
2009-01-13 Wim Taymans <wim.taymans@collabora.co.uk>
 
* tests/examples/rtp/server-alsasrc-PCMA.c: (print_source_stats),
......
plugin_LTLIBRARIES = libgstosxaudio.la
libgstosxaudio_la_SOURCES = gstosxringbuffer.c \
gstosxaudioelement.c \
gstosxaudiosink.c \
gstosxaudiosrc.c \
gstosxaudio.c
libgstosxaudio_la_SOURCES = gstosxringbuffer.c \
gstosxaudioelement.c \
gstosxaudiosink.c \
gstosxaudiosrc.c \
gstosxaudio.c
libgstosxaudio_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \
-Wno-deprecated-declarations
libgstosxaudio_la_LIBADD = \
-lgstinterfaces-@GST_MAJORMINOR@ \
-lgstaudio-@GST_MAJORMINOR@ \
$(GST_PLUGINS_BASE_LIBS) \
$(GST_LIBS)
libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,CoreAudio
-Wno-deprecated-declarations
libgstosxaudio_la_LIBADD = \
-lgstinterfaces-@GST_MAJORMINOR@ \
-lgstaudio-@GST_MAJORMINOR@ \
$(GST_PLUGINS_BASE_LIBS) \
$(GST_LIBS)
libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,CoreAudio,-framework -Wl,AudioUnit
libgstosxaudio_la_LIBTOOLFLAGS = --tag=disable-static
noinst_HEADERS = gstosxaudiosink.h \
gstosxaudioelement.h \
gstosxringbuffer.h \
gstosxaudiosrc.h
noinst_HEADERS = gstosxaudiosink.h \
gstosxaudioelement.h \
gstosxringbuffer.h \
gstosxaudiosrc.h
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment