Commit 2a4e3d21 authored by Sebastian Dröge's avatar Sebastian Dröge

vpx: Rename vp8 plugin to vpx

This is using libvpx, which can support more codecs than just VP8
and will likely support future codecs.
parent eed915b0
plugin_LTLIBRARIES = \
libgstvp8.la
libgstvpx.la
libgstvp8_la_SOURCES = \
libgstvpx_la_SOURCES = \
gstvp8dec.c \
gstvp8enc.c \
gstvp8utils.c \
plugin.c
libgstvp8_la_CFLAGS = \
libgstvpx_la_CFLAGS = \
$(GST_PLUGINS_BASE_CFLAGS) \
$(GST_BASE_CFLAGS) \
$(GST_CFLAGS) \
$(VPX_CFLAGS) \
-DGST_USE_UNSTABLE_API
libgstvp8_la_LIBADD = \
libgstvpx_la_LIBADD = \
$(GST_PLUGINS_BASE_LIBS) -lgsttag-@GST_API_VERSION@ -lgstvideo-@GST_API_VERSION@ \
$(GST_BASE_LIBS) $(GST_LIBS) $(VPX_LIBS)
libgstvp8_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstvp8_la_LIBTOOLFLAGS = --tag=disable-static
libgstvpx_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstvpx_la_LIBTOOLFLAGS = --tag=disable-static
noinst_HEADERS = \
gstvp8dec.h \
......
......@@ -46,6 +46,6 @@ plugin_init (GstPlugin * plugin)
GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
GST_VERSION_MINOR,
vp8,
vpx,
"VP8 plugin",
plugin_init, VERSION, "LGPL", GST_PACKAGE_NAME, GST_PACKAGE_ORIGIN)
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment