Commit 7968098f authored by Jeff McGee's avatar Jeff McGee Committed by Daniel Vetter

tests/pm_sseu: Require Gen8+ early in setup

Pre-Gen8 devices should be skipped early instead of failing
when test resources are not found.

Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=89822Signed-off-by: 's avatarJeff McGee <jeff.mcgee@intel.com>
parent a6c3b326
......@@ -262,6 +262,8 @@ gem_init(void)
gem.devid = intel_get_drm_devid(gem.drm_fd);
gem.gen = intel_gen(gem.devid);
igt_require_f(gem.gen >= 8,
"SSEU power gating only relevant for Gen8+");
gem.has_ppgtt = gem_uses_aliasing_ppgtt(gem.drm_fd);
gem.bufmgr = drm_intel_bufmgr_gem_init(gem.drm_fd, 4096);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment