Commit 340d114c authored by Will Thompson's avatar Will Thompson

Use Automake 1.11, if available, for silent rules

Automake 1.11 adds support for silent rules, which are conditionally
enabled in configure.in if available.

Also, previously it was impossible to override the version chosen by
this script; this patch makes that possible.
parent 4510983f
......@@ -27,8 +27,12 @@ fi
DIE=1
}
AUTOMAKE=automake-1.9
ACLOCAL=aclocal-1.9
# If the user hasn't explicitly chosen an Automake version, use 1.11. This is
# the earliest version that gives us silent rules.
if test -z "$AUTOMAKE"; then
AUTOMAKE=automake-1.11
ACLOCAL=aclocal-1.11
fi
($AUTOMAKE --version) < /dev/null > /dev/null 2>&1 || {
AUTOMAKE=automake
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment