Commit 28c27349 authored by Simon McVittie's avatar Simon McVittie

CI: Start supporting Debian 10 'buster', currently under development

This gives us a way to build on a more recent host OS if we want to.
For Gitlab-CI it's disabled by default.
Signed-off-by: Simon McVittie's avatarSimon McVittie <smcv@collabora.com>
parent 0c553afc
Pipeline #11030 failed with stage
in 0 seconds
......@@ -126,6 +126,14 @@ build:jessie:
ci_suite: "jessie"
script: *script
build:buster:
when: manual
stage: build
image: "debian:buster-slim"
variables:
ci_suite: "buster"
script: *script
build:xenial:
when: manual
stage: build
......
......@@ -41,5 +41,6 @@ env:
- ci_host=x86_64-w64-mingw32 ci_buildsys=cmake
- ci_docker=debian:jessie-slim ci_distro=debian ci_suite=jessie
- ci_docker=debian:stretch-slim ci_distro=debian ci_suite=stretch
- ci_docker=debian:buster-slim ci_distro=debian ci_suite=buster
# vim:set sw=2 sts=2 et:
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment