Commit 09c48920 authored by John Palmieri's avatar John Palmieri

* INSTALL: remove dependancies for bindings since they no longer

  are a part of core
parent 783e066c
2007-05-25 John (J5) Palmieri <johnp@redhat.com>
* INSTALL: remove dependancies for bindings since they no longer
are a part of core
2007-05-25 Ralf Habacker <ralf.habacker@freenet.de>
* dbus/dbus-server-win.c,dbus/dbus-server-win.h: new file
......
......@@ -45,66 +45,6 @@ Core library
- doxygen (for API documentation)
- xmlto (for Spec & other XML documentation)
GLib Bindings
-------------
Requisite:
- GLib >= 2.4
Optional:
- GTK+ >= 2.4 (for dbus-viewer tool)
Qt Bindings
-----------
Requisite:
- QtCore and QtXml >= 4.1.3
Optional:
- QtTest (for Qt Unit tests)
- QtGui >= 4.1.3 (for the chat example program)
Note: Qt 4.1.3 is not available in released form. You need to download
the 4.1.3 snapshots from Trolltech. However, the Qt binding compiles
and works in Qt 4.1.2, but not the dbusidl2cpp tool.
Note that DBus detects QtCore and QtXml during the configure process
using pkg-config. You may need to set the PKG_CONFIG_PATH to include
the Qt4 library directory. If you don't have your Qt4 installed, then
you may also need to use the --with-qt-moc directive to point to the
Qt4 moc executable (e.g. $QTDIR/bin/moc).
Qt 3 Bindings
-------------
Requisite:
- Qt >= 3.1
Mono Bindings
-------------
Requisite:
- Mono >= 0.95
Optional:
- MonoDoc >= 0.16 (for API documentation)
Python Bindings
---------------
Requisite:
- Python >= 2.4
- Pyrex
====================================================================
The rest of this document contains the generic GNU AutoTools install
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment