Commit c4640c6f authored by Simon McVittie's avatar Simon McVittie

Install mingw build-dependencies in a different order

This avoids installing the build-dependencies for dbus and its tests,
then uninstalling them all because they rely on libraries whose versions
are older than the ones needed by wine:i386 (and apparently apt prefers
to remove those libraries rather than upgrade them). Doing it this way
round seems to convince apt to do the right thing.
Signed-off-by: default avatarSimon McVittie <simon.mcvittie@collabora.co.uk>
parent 07ec3ecf
......@@ -6,6 +6,9 @@ install:
- ": | sudo tee /etc/apt/sources.list.d/google-chrome.list"
- test "$dbus_ci_host" != mingw || sudo dpkg --add-architecture i386
- sudo apt-get -qq -y update
- >
test "$dbus_ci_host" != mingw || sudo apt-get -qq -y install
binutils-mingw-w64-i686 g++-mingw-w64-i686 wine:i386
- sudo apt-get -qq -y build-dep dbus
- >
sudo apt-get -qq -y install
......@@ -31,9 +34,6 @@ install:
xmlto
xsltproc
xvfb
- >
test "$dbus_ci_host" != mingw || sudo apt-get -qq -y install
binutils-mingw-w64-i686 g++-mingw-w64-i686 wine:i386
script:
# python-dbus and python-gi aren't available to Travis's version of
# Python in /opt, which it uses as a default
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment