glamor: Only use dual blending with GLSL >= 1.30

It can't be used with older GLSL. Fixes a crash when attempting to
anyway.

Closes: xorg/xserver#97
Fixes: e7308b6c "glamor: Add support for CA rendering in a single pass."
Reviewed-by: Dave Airlie <airlied@redhat.com>
Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
3 jobs for glamor-dual_blend-glsl-1.30 in 6 minutes and 55 seconds (queued for 1 second)
Status Job ID Name Coverage
  Docker Image
passed #1212617
debian-testing

00:00:30

 
  Build And Test
passed #1212618
autotools-build-and-test

00:06:24

passed #1212619
meson-build-and-test

00:01:37