lib: Avoid linking to system-installed library

When building geoclue, in some cases the already installed library is
prefered for linking rather than the one from the build directory. This
causes problems when an old version is already installed and one is
adding new API.

This commit partially adresses this issue. A similar issue appears to
exist when building the documentation though.
3 jobs for benzea/auto-close-client in 10 minutes and 54 seconds (queued for 18 minutes and 47 seconds)
Status Job ID Name Coverage
  Test
passed #158471
ubuntu-16.04

00:03:56

passed #158472
ubuntu-17.10

00:03:32

passed #158473
ubuntu-18.04

00:03:25