meson: Bump required meson version to 0.46

We were being naughty:

WARNING: Project specifies a minimum meson_version '>= 0.42.0' but uses features which were added in newer versions:
 * 0.46.0: {'compiler.has_multi_link_argument', 'compiler.has_link_argument'}
3 jobs for meson-version in 5 minutes and 8 seconds (queued for 35 minutes and 29 seconds)
Status Job ID Name Coverage
  Docker Image
passed #154168
debian-testing

00:00:24

 
  Build And Test
passed #154169
autotools-build-and-test

00:03:50

passed #154170
meson-build-and-test

00:00:52