Commit ad6689b7 authored by Mariusz Bialonczyk's avatar Mariusz Bialonczyk Committed by Michel Dänzer

configure.ac: fix checking for libdrm version after 9232835b

No matter what libdrm version was installed, it always set
the GLAMOR_HAS_DRM_NAME_FROM_FD_2 conditional to 1.
This obviously leads to compilation problems.

Fixes: 9232835b ("glamor: use drmGetDeviceNameFromFD2 when available")
Signed-off-by: default avatarMariusz Bialonczyk <manio@skyboo.net>
Reviewed-and-Tested-by: default avatarQiang Yu <Qiang.Yu@amd.com>
parent eb2cf117
......@@ -2167,8 +2167,9 @@ if test "x$GLAMOR" = xyes; then
fi
fi
PKG_CHECK_MODULES(LIBDRM, "libdrm >= 2.4.74",
[AC_DEFINE(GLAMOR_HAS_DRM_NAME_FROM_FD_2, 1, [Have GLAMOR_HAS_DRM_NAME_FROM_FD_2])], [])
PKG_CHECK_EXISTS(libdrm >= 2.4.74,
[AC_DEFINE(GLAMOR_HAS_DRM_NAME_FROM_FD_2, 1, [Have GLAMOR_HAS_DRM_NAME_FROM_FD_2])],
[])
fi
AM_CONDITIONAL([GLAMOR_EGL], [test "x$GBM" = xyes])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment