• Jamey Sharp's avatar
    Xserver need not be compatible with old versions of xserver. · e4d4d6dd
    Jamey Sharp authored
    Delete time-traveling multiple personality disorder from the server.
    
    Gaetan notes:
    
        There were a couple of drivers containing an unknown version of the
        modes/parser code. This was done in server 1.2 time frame because it
        was released without mode code. It was barely or not maintained
        afterwards. There are currently no video drivers with a copy of the
        modes code.
    
    Most of these ifdefs were introduced in commit
    a8d760f5, where Aaron wrote,
    
        This change uses XORG_VERSION_CURRENT < 7.0 to mean "server newer
        than 1.2" since XORG_VERSION current went backwards at some point.
    
    Alan explains that:
    
        In Xorg 1.3, when we first released an Xorg server release decoupled
        from the katamari release schedule.  (1.0 through 1.2 were released
        as part of X11R7.0 through 7.2, while 1.3 came out between X11R7.2 &
        7.3.)
    
    Commit by Jamey Sharp and Josh Triplett.
    Signed-off-by: Jamey Sharp's avatarJamey Sharp <jamey@minilop.net>
    Signed-off-by: Josh Triplett's avatarJosh Triplett <josh@joshtriplett.org>
    Reviewed-by: Aaron Plattner's avatarAaron Plattner <aplattner@nvidia.com>
    e4d4d6dd
xf86EdidModes.c 50.9 KB