gallium: Require LLVM >= 3.9

To go any further than this would be to break the current version of
Android.

Reviewed-by: Timothy Arceri <tarceri@itsqueeze.com>
Reviewed-by: Jose Fonseca <jfonseca@vmware.com>
22 jobs for !1858 with require-llvm-3.9 in 34 minutes and 13 seconds (queued for 19 seconds)
merge request