glx: Remove GLXQueryContextInfoEXT fallback

GLX_EXT_libglvnd requires GLX 1.3, we can assume GLXQueryContext works.
12 jobs for drop-query-context-info-ext-fallback in 2 minutes and 1 second (queued for 1 second)
latest