Commit 917ecfcb authored by Pekka Paalanen's avatar Pekka Paalanen Committed by Daniel Stone
Browse files

meson: better error for test-junit-xml dep



Helps people avoid libxml if they... want to?
Signed-off-by: Pekka Paalanen's avatarPekka Paalanen <pq@iki.fi>
parent 5605b72e
......@@ -52,7 +52,11 @@ exe_plugin_test = shared_library(
deps_zuc = [ dep_libshared ]
if get_option('test-junit-xml')
deps_zuc += [ dependency('libxml-2.0', version: '>= 2.6') ]
d = dependency('libxml-2.0', version: '>= 2.6', required: false)
if not d.found()
error('JUnit XML support requires libxml-2.0 >= 2.6 which was not found. Or, you can use \'-Dtest-junit-xml=false\'.')
endif
deps_zuc += d
config_h.set('ENABLE_JUNIT_XML', '1')
endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment