Commit 83a46ca9 authored by Pekka Paalanen's avatar Pekka Paalanen
Browse files

meson: better error for x11+gl deps



Helps people avoid egl in the rare case they don't have it.
Signed-off-by: Pekka Paalanen's avatarPekka Paalanen <pq@iki.fi>
parent 43a42920
......@@ -364,7 +364,11 @@ if get_option('backend-x11')
endif
if get_option('renderer-gl')
deps_x11 += dependency('egl')
d = dependency('egl', required: false)
if not d.found()
error('x11-backend + gl-renderer requires egl which was not found. Or, you can use \'-Dbackend-x11=false\' or \'-Drenderer-gl=false\'.')
endif
deps_x11 += d
endif
plugin_x11 = shared_library(
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment