Commit 217a15c1 authored by Pekka Paalanen's avatar Pekka Paalanen
Browse files

meson: better error for cms-colord deps



Helps people avoid colord if they don't want it.
Signed-off-by: Pekka Paalanen's avatarPekka Paalanen <pq@iki.fi>
parent 37dabe5f
......@@ -107,15 +107,17 @@ if get_option('color-management-colord')
'cms-colord.c',
'cms-helper.c',
]
deps_colord = [
dep_libweston,
dependency('colord', version: '>= 0.1.27')
]
dep_colord = dependency('colord', version: '>= 0.1.27', required: false)
if not dep_colord.found()
error('cms-colord requires colord >= 0.1.27 which was not found. Or, you can use \'-Dcolor-management-colord=false\'.')
endif
plugin_colord = shared_library(
'cms-colord',
srcs_colord,
include_directories: include_directories('..', '../shared'),
dependencies: deps_colord,
dependencies: [ dep_libweston, dep_colord ],
name_prefix: '',
install: true,
install_dir: dir_module_weston
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment