Commit e265ae2d authored by Brian Cameron's avatar Brian Cameron Committed by Albert Astals Cid

Add uninstalled .pc file for poppler when using autoconf

parent 552ab99e
......@@ -39,10 +39,17 @@ SUBDIRS = goo fofi $(splash_subdir) poppler $(utils_subdir) $(glib_subdir) $(qt_
EXTRA_DIST = \
README-XPDF \
poppler.pc.in \
poppler-uninstalled.pc.in \
poppler-cairo.pc.in \
poppler-cairo-uninstalled.pc.in \
poppler-splash.pc.in \
poppler-splash-uninstalled.pc.in \
poppler-qt.pc.in \
poppler-cpp.pc.in
poppler-qt-uninstalled.pc.in \
poppler-qt4.pc.in \
poppler-qt4-uninstalled.pc.in \
poppler-cpp.pc.in \
poppler-cpp-uninstalled.pc.in
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = \
......
......@@ -653,12 +653,19 @@ cpp/Makefile
cpp/poppler-version.h
cpp/tests/Makefile
poppler.pc
poppler-uninstalled.pc
poppler-cairo.pc
poppler-cairo-uninstalled.pc
poppler-splash.pc
poppler-splash-uninstalled.pc
poppler-glib.pc
poppler-glib-uninstalled.pc
poppler-qt.pc
poppler-qt-uninstalled.pc
poppler-qt4.pc
poppler-cpp.pc])
poppler-qt4-uninstalled.pc
poppler-cpp.pc
poppler-cpp-uninstalled.pc])
echo ""
......
Name: poppler-cairo
Description: Cairo backend for Poppler PDF rendering library - uninstalled
Version: @VERSION@
Requires: poppler = @VERSION@ cairo >= @CAIRO_VERSION@
Libs: ${pc_top_builddir}/${pcfiledir}/poppler/libpoppler-cairo.la
Name: poppler-cpp
Description: cpp backend for Poppler PDF rendering library - uninstalled
Version: @VERSION@
Requires: poppler = @VERSION@
Libs: ${pc_top_builddir}/${pcfiledir}/cpp/libpoppler-cpp.la
Cflags: -I${pc_top_builddir}/${pcfiledir}/cpp
Name: poppler-glib
Description: GLib wrapper for poppler - uninstalled
Version: @VERSION@
Requires: poppler-cairo = @VERSION@ @GLIB_REQ@ @GDK_REQ@
Libs: ${pc_top_builddir}/${pcfiledir}/glib/libpoppler-glib.la
Cflags: -I${pc_top_builddir}/${pcfiledir}/glib
Name: poppler-qt
Description: Qt bindings for poppler - uninstalled
Version: @VERSION@
Requires: poppler = @VERSION@
Libs: ${pc_top_builddir}/${pcfiledir}/qt/libpoppler-qt.la
Cflags: -I${pc_top_builddir}/${pcfiledir}/qt
Name: poppler-qt4
Description: Qt4 bindings for poppler - uninstalled
Version: @VERSION@
Requires: poppler = @VERSION@
Libs: ${pc_top_builddir}/${pcfiledir}/qt4/src/libpoppler-qt4.la
Cflags: -I${pc_top_builddir}/${pcfiledir}/qt4/src
Name: poppler-splash
Description: Splash backend for Poppler PDF rendering library - uninstalled
Version: @VERSION@
Requires: poppler = @VERSION@
Libs: ${pc_top_builddir}/${pcfiledir}/splash/libsplash.la
Name: poppler
Description: PDF rendering library - uninstalled
Version: @VERSION@
Libs: ${pc_top_builddir}/${pcfiledir}/poppler/libpoppler.la
Cflags: -I${pc_top_builddir}/${pcfiledir}/poppler
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment