Commit 5bbb2fc4 authored by Adam Reichold's avatar Adam Reichold

Add a separate build job using Ubuntu 14.04 and GCC 4.9 to compatibility with older systems.

parent 560b34a6
Pipeline #4531 passed with stage
in 9 minutes and 42 seconds
......@@ -13,6 +13,11 @@ variables:
LANGUAGE: en_US:en
LC_ALL: en_US.UTF-8
cache:
key: "$CI_BUILD_NAME"
paths:
- build/
build:
stage: build
script:
......@@ -21,18 +26,32 @@ build:
- cmake -G Ninja -DTESTDATADIR=$PWD/test-master ..
- ninja
- ctest --output-on-failure
cache:
paths:
- build/
build_clang_libcpp:
stage: build
script:
- mkdir -p build_clang && cd build_clang
- mkdir -p build && cd build
- curl https://gitlab.freedesktop.org/poppler/test/-/archive/master/test-master.tar.gz | tar xz
- CXX=clang++ cmake -G Ninja -DCMAKE_CXX_FLAGS=-stdlib=libc++ -DTESTDATADIR=$PWD/test-master ..
- CC=clang CXX=clang++ cmake -G Ninja -DCMAKE_CXX_FLAGS=-stdlib=libc++ -DTESTDATADIR=$PWD/test-master ..
- ninja
- ctest --output-on-failure
cache:
paths:
- build_clang/
build_gcc_49:
stage: build
image: ubuntu:trusty
before_script:
- apt-get update
- apt-get install --yes software-properties-common
- add-apt-repository --yes ppa:ubuntu-toolchain-r/test
- add-apt-repository --yes ppa:george-edison55/cmake-3.x
- add-apt-repository --yes ppa:ricotz/testing
- add-apt-repository --yes ppa:aacid/openjp2trusty
- apt-get update
- apt-get install --yes build-essential cmake ninja-build gcc-4.9 g++-4.9 libjpeg-dev libopenjp2-7-dev qtbase5-dev gobject-introspection libglib2.0-dev libgtk-3-dev libgirepository1.0-dev libnss3-dev
- update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.9 20
- update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.9 20
- update-alternatives --install /usr/bin/gcov gcov /usr/bin/gcov-4.9 20
script:
- mkdir -p build && cd build
- cmake -G Ninja ..
- ninja
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment