Commit edb7395b authored by Robert Ancell's avatar Robert Ancell

Require glib 2.44 for g_auto

parent b6a80f88
......@@ -25,17 +25,11 @@ AC_SUBST(LT_CURRENT)
AC_SUBST(LT_REVISION)
AC_SUBST(LT_AGE)
PKG_CHECK_MODULES(GIO, gio-2.0 >= 2.37.3 gio-unix-2.0)
PKG_CHECK_MODULES(POLKIT, gio-unix-2.0 polkit-gobject-1)
PKG_CHECK_MODULES(LIBACCOUNTSSERVICE, glib-2.0 >= 2.44 gio-2.0 >= 2.37.3 gio-unix-2.0)
PKG_CHECK_MODULES(ACCOUNTS_DAEMON, glib-2.0 >= 2.44 gio-unix-2.0 polkit-gobject-1)
AM_MAINTAINER_MODE([enable])
# client library dependencies
LIBACCOUNTSSERVICE_LIBS="$GIO_LIBS"
AC_SUBST(LIBACCOUNTSSERVICE_LIBS)
LIBACCOUNTSSERVICE_CFLAGS="$GIO_CFLAGS"
AC_SUBST(LIBACCOUNTSSERVICE_CFLAGS)
GOBJECT_INTROSPECTION_CHECK([0.9.12])
dnl ---------------------------------------------------------------------------
......
......@@ -20,11 +20,11 @@ IGNORE_HFILES= \
GTKDOC_CFLAGS= \
-I$(top_srcdir)/src/libaccountsservice \
$(GIO_CFLAGS)
$(LIBACCOUNTSSERVICE_CFLAGS)
GTKDOC_LIBS= \
$(top_builddir)/src/libaccountsservice/libaccountsservice.la \
$(GIO_LIBS)
$(LIBACCOUNTSSERVICE_LIBS)
include $(top_srcdir)/gtk-doc.make
......
......@@ -8,7 +8,7 @@ INCLUDES = \
-DUSERDIR=\"$(localstatedir)/lib/AccountsService/users\" \
-I$(srcdir) \
-I$(builddir) \
$(POLKIT_CFLAGS) \
$(ACCOUNTS_DAEMON_CFLAGS) \
$(WARN_CFLAGS)
noinst_LTLIBRARIES = libaccounts-generated.la
......@@ -47,7 +47,7 @@ accounts_daemon_SOURCES = \
accounts_daemon_LDADD = \
libaccounts-generated.la \
$(POLKIT_LIBS)
$(ACCOUNTS_DAEMON_LIBS)
EXTRA_DIST = \
fgetpwent.c \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment