Commit d4c6d4d5 authored by Eric Engestrom's avatar Eric Engestrom 💤
Browse files

gitlab-ci: add scons llvm 3.5 build


Signed-off-by: Eric Engestrom's avatarEric Engestrom <eric.engestrom@intel.com>
parent 06b245b4
......@@ -116,6 +116,9 @@ containers:ubuntu:
variables:
SCONSFLAGS: "-j4"
script:
- if test -n "$LLVM_VERSION"; then
export LLVM_CONFIG="llvm-config-${LLVM_VERSION}";
fi
- scons $SCONS_TARGET
- eval $SCONS_CHECK_COMMAND
......@@ -171,3 +174,10 @@ build:scons-nollvm:
variables:
SCONS_TARGET: "llvm=0"
SCONS_CHECK_COMMAND: "scons llvm=0 check"
build:scons-llvm:
extends: .scons-build
variables:
SCONS_TARGET: "llvm=1"
SCONS_CHECK_COMMAND: "scons llvm=1 check"
LLVM_VERSION: "3.9"
......@@ -20,6 +20,8 @@ RUN apt-get install -y \
libxshmfence-dev \
libvdpau-dev \
libva-dev \
llvm-3.9-dev \
libclang-3.9-dev \
llvm-7-dev \
xz-utils \
libexpat1-dev \
......
......@@ -530,28 +530,6 @@ matrix:
- libunwind8-dev
- python3-pip
- python3-setuptools
- env:
- LABEL="scons LLVM"
- BUILD=scons
- SCONSFLAGS="-j4"
- SCONS_TARGET="llvm=1"
# Keep it symmetrical to the make build.
- SCONS_CHECK_COMMAND="scons llvm=1 check"
- LLVM_VERSION=3.5
- LLVM_CONFIG="llvm-config-${LLVM_VERSION}"
addons:
apt:
packages:
# LLVM packaging is broken and misses these dependencies
- libedit-dev
# We actually want to test against llvm-3.3, yet 3.5 is available
- llvm-3.5-dev
# Common
- xz-utils
- x11proto-xf86vidmode-dev
- libexpat1-dev
- libx11-xcb-dev
- libelf-dev
- env:
- LABEL="scons SWR"
- BUILD=scons
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment