Commit cc85f500 authored by Eric Engestrom's avatar Eric Engestrom 💤
Browse files

gitlab-ci: add make Gallium ST Clover LLVM-4.0 build


Signed-off-by: Eric Engestrom's avatarEric Engestrom <eric.engestrom@intel.com>
parent 984e2955
......@@ -389,6 +389,11 @@ build:make-gallium-st-clover-llvm-39:
GALLIUM_DRIVERS: "r600"
LIBUNWIND_FLAGS: --enable-libunwind
build:make-gallium-st-clover-llvm-4:
extends: build:make-gallium-st-clover-llvm-39
variables:
LLVM_VERSION: "4.0"
build:scons-nollvm:
extends: .scons-build
variables:
......
......@@ -25,6 +25,8 @@ RUN apt-get install -y \
libva-dev \
llvm-3.9-dev \
libclang-3.9-dev \
llvm-4.0-dev \
libclang-4.0-dev \
llvm-5.0-dev \
llvm-6.0-dev \
llvm-7-dev \
......
......@@ -31,36 +31,6 @@ env:
matrix:
include:
- env:
- LABEL="make Gallium ST Clover LLVM-4.0"
- BUILD=make
- MAKEFLAGS="-j4"
- MAKE_CHECK_COMMAND="true"
- LLVM_VERSION=4.0
- LLVM_CONFIG="llvm-config-${LLVM_VERSION}"
- DRI_LOADERS="--disable-glx --disable-gbm --disable-egl"
- DRI_DRIVERS=""
- GALLIUM_ST="--disable-dri --enable-opencl --enable-opencl-icd --enable-llvm --disable-xa --disable-nine --disable-xvmc --disable-vdpau --disable-va --disable-omx-bellagio --disable-gallium-osmesa"
- GALLIUM_DRIVERS="r600"
- VULKAN_DRIVERS=""
- LIBUNWIND_FLAGS="--enable-libunwind"
addons:
apt:
packages:
- libclc-dev
# LLVM packaging is broken and misses these dependencies
- libedit-dev
- llvm-4.0-dev
- clang-4.0
- libclang-4.0-dev
# Common
- xz-utils
- libexpat1-dev
- libx11-xcb-dev
- libelf-dev
- libunwind8-dev
- python3-pip
- python3-setuptools
- env:
- LABEL="make Gallium ST Clover LLVM-5.0"
- BUILD=make
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment