bluetooth: Rename rtp_sbc_payload to rtp_payload

Now that we use RTP payload structure for LDAC as well, rename
rtp_sbc_payload to rtp_payload. PipeWire also uses the same naming.

Part-of: <pulseaudio/pulseaudio!689>
2 jobs for ldac-without-rtpldacpay in 2 minutes and 4 seconds (queued for 5 seconds)