all: goodbye libnm-glib

This removes libnm-glib, libnm-glib-vpn, and libnm-util for good.
The it has been replaced with libnm since NetworkManager 1.0, disabled
by default since 1.12 and no up-to-date distributions ship it for years
now.

Removing the libraries allows us to:

* Remove the horrible hacks that were in place to deal with accidental use
  of both the new and old library in a single process.
* Relief the translators of maintenance burden of similar yet different
  strings.
* Get rid of known bad code without chances of ever getting fixed
  (libnm-glib/nm-object.c and libnm-glib/nm-object-cache.c)
* Generally lower the footprint of the releases and our workspace

If there are some really really legacy users; they can just build
libnm-glib and friends from the NetworkManager-1.16 distribution. The
D-Bus API is stable and old libnm-glib will keep working forever.

https://github.com/NetworkManager/NetworkManager/pull/308
7 jobs for master in 31 minutes and 41 seconds (queued for 1 second)
Status Job ID Name Coverage
  Test
passed #241291
build_f28

00:29:31

passed #241292
build_f29

00:30:43

passed #241293
build_f30

00:31:08

failed #241294
allowed to fail
build_frawhide

00:00:44

passed #241290
checkpatch

00:01:00

 
  Deploy
passed #241295
pages

00:00:31

failed pages:deploy

00:00:00

 
Name Stage Failure
failed
build_frawhide Test
Checking out 5801f89f as master...

Skipping Git submodules setup
$ date '+%Y%m%d-%H%M%S'; NM_INSTALL="dnf install -y" ./contrib/fedora/REQUIRED_PACKAGES
20190416-135256
Fedora - Modular Rawhide - Developmental packag 0.0 B/s | 0 B 00:29
Failed to synchronize cache for repo 'rawhide-modular'
Error: Failed to synchronize cache for repo 'rawhide-modular'
ERROR: Job failed: exit code 1