Commit 7307dea9 authored by Francesco Giudici's avatar Francesco Giudici Committed by Lubomir Rintel

connectivity: switch connectivity checking to libcurl

[lkundrak@v3.sk: removed libsoup altogether, implemented TODOs and fixed
the poll condition handling]
Co-authored-by: Lubomir Rintel's avatarLubomir Rintel <lkundrak@v3.sk>
parent 724b600a
......@@ -1035,7 +1035,7 @@ src_cppflags = \
$(LIBNL_CFLAGS) \
$(LIBNDP_CFLAGS) \
$(LIBPSL_CFLAGS) \
$(LIBSOUP_CFLAGS) \
$(LIBCURL_CFLAGS) \
$(SELINUX_CFLAGS) \
$(LIBAUDIT_CFLAGS) \
$(SYSTEMD_LOGIN_CFLAGS) \
......@@ -1472,7 +1472,7 @@ src_libNetworkManager_la_LIBADD = \
$(SELINUX_LIBS) \
$(LIBAUDIT_LIBS) \
$(LIBPSL_LIBS) \
$(LIBSOUP_LIBS)
$(LIBCURL_LIBS)
###############################################################################
......
......@@ -978,28 +978,13 @@ else
fi
AM_CONDITIONAL(WITH_LIBPSL, test "$with_libpsl" != "no")
PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4 >= 2.40], [have_libsoup=yes],[have_libsoup=no])
AC_ARG_WITH(libsoup, AS_HELP_STRING([--with-libsoup=yes|no], [Link against libsoup]), [], [with_libsoup=${have_libsoup}])
if test "$with_libsoup" != "no"; then
if test "$have_libsoup" != "yes"; then
AC_MSG_ERROR(libsoup library not found)
fi
with_libsoup='yes'
AC_DEFINE(WITH_LIBSOUP, 1, [Define if you have libsoup])
else
AC_DEFINE(WITH_LIBSOUP, 0, [Define if you have libsoup])
fi
AM_CONDITIONAL(WITH_LIBSOUP, test "$with_libsoup" != "no")
LIBSOUP_CFLAGS="$LIBSOUP_CFLAGS -DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_40 -DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_2_40"
AC_ARG_ENABLE(concheck, AS_HELP_STRING([--enable-concheck], [enable connectivity checking support]),
[enable_concheck=${enableval}], [enable_concheck=${with_libsoup}])
[enable_concheck=${enableval}], [enable_concheck=${with_libcurl}])
if (test "${enable_concheck}" = "yes"); then
if test x"$with_libsoup" = x"no"; then
AC_MSG_ERROR(Connectivity checking requires libsoup)
fi
PKG_CHECK_MODULES(LIBCURL, [libcurl >= 7.24.0])
AC_DEFINE(WITH_CONCHECK, 1, [Define if you want connectivity checking support])
else
enable_concheck=no
AC_DEFINE(WITH_CONCHECK, 0, [Define if you want connectivity checking support])
fi
AM_CONDITIONAL(WITH_CONCHECK, test "${enable_concheck}" = "yes")
......
......@@ -36,7 +36,7 @@ yum install \
wireless-tools-devel \
polkit-devel \
libpsl-devel \
libsoup-devel \
libcurl-devel \
readline-devel \
teamd-devel \
rpm-build \
......
......@@ -138,7 +138,7 @@ BuildRequires: bluez-libs-devel
%endif
BuildRequires: systemd >= 200-3 systemd-devel
BuildRequires: libpsl-devel >= 0.1
BuildRequires: libsoup-devel
BuildRequires: libcurl-devel
BuildRequires: libndp-devel >= 1.0
%if 0%{?with_modem_manager_1}
BuildRequires: ModemManager-glib-devel >= 1.0
......
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment