Commit 1a2a5b37 authored by Thomas Haller's avatar Thomas Haller

tests: don't install unnecessary package in gitlab-ci tests

REQUIRED_PACKAGES has two uses:

 - to setup a system for developing NetworkManager. This installs
   convenience packages like "cscope".

 - to install the packages required for unit testing in gitlab-ci.

For gitlab-ci we should only install the packages that we actually
need.
parent 18556755
......@@ -16,7 +16,7 @@ stages:
- date '+%Y%m%d-%H%M%S'; ! grep -q '^NAME=.*\(CentOS\)' /etc/os-release || (yum install -y glibc-common && localedef -c -i pl_PL -f UTF-8 pl_PL.UTF-8 && locale -a)
- date '+%Y%m%d-%H%M%S'; NM_INSTALL="yum install -y" ./contrib/fedora/REQUIRED_PACKAGES
- date '+%Y%m%d-%H%M%S'; NM_NO_EXTRA=1 NM_INSTALL="yum install -y" ./contrib/fedora/REQUIRED_PACKAGES
- date '+%Y%m%d-%H%M%S'; yum install -y glibc-langpack-pl ccache clang which
# containers have "tsflags=nodocs" in /etc/dnf/dnf.conf. We need /usr/shared/gtk-doc/html
......
......@@ -28,15 +28,23 @@ install_ignore_missing() {
done
}
if test "$NM_NO_EXTRA" != 1; then
# these packages are convenient for developing, but not necessary
# for CI testing.
EXTRA_PACKAGES=(
bash-completion \
cscope \
)
else
EXTRA_PACKAGES=()
fi
install \
ModemManager-devel \
ModemManager-glib-devel \
mobile-broadband-provider-info-devel \
audit-libs-devel \
bash-completion \
bluez-libs-devel \
bzip2 \
cscope \
dbus-devel \
dbus-python \
dbus-x11 \
......@@ -59,6 +67,7 @@ install \
libuuid-devel \
make \
meson \
mobile-broadband-provider-info-devel \
newt-devel \
nss-devel \
polkit-devel \
......@@ -76,7 +85,7 @@ install \
vala-tools \
valgrind \
wireless-tools-devel \
#end
"${EXTRA_PACKAGES[@]}"
# some packages don't exist in certain distributions. Install them one-by-one, and ignore errors.
install_ignore_missing \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment