Commit 065741c7 authored by Thomas Haller's avatar Thomas Haller

travis: install meson 0.44.1 for travis' meson build

Latest versions of meson require now Python 3.5+. Not only that meson requires Python3
and thus makes building on some systems cumbersome (RHEL7), it also eagerly bumps
Python3.y requirements.

Install the last working release which works with Python3.4. This fixes
the the travis build failure on Ubuntu 14.04 (trusty):

  Meson works correctly only with python 3.5+.
  You have python 3.4.3 (default, Nov 28 2017, 16:41:13)
  [GCC 4.8.4].
  Please update your environment
parent dd01418b
......@@ -61,7 +61,18 @@ before_install:
./configure.py --bootstrap &&
sudo cp ninja /usr/bin/ &&
popd
sudo pip3 install meson
# Recent meson requires python 3.5, which isn't in Ubuntu 14.04.
# Hence we cannot install it via `pip3 install meson`. Install the latest
# working release.
#
# Wouldn't it be nice to have a build system that supports everything
# that NetworkManager would like to support?
wget https://github.com/mesonbuild/meson/releases/download/0.44.1/meson-0.44.1.tar.gz -O /tmp/meson.tar.gz
tar -C /tmp -xvzf /tmp/meson.tar.gz
pushd /tmp/meson-0.44.1
sudo python3 setup.py install
popd
fi
- sudo chmod o+x /usr/sbin/pppd
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment