Skip to content
  • Thomas Haller's avatar
    contrib/rpm: disable NDEBUG for meson builds · ef338667
    Thomas Haller authored
    For better or worse, our release builds commonly do not disable assertions.
    That means,
    
     - NDEBUG is not set, and assert() is in effect
     - G_DISABLE_ASSERT is not set, and g_assert() is in effect
     - G_DISABLE_CHECKS is not set, and g_return*() is in effect.
    
    On the other hand, NM_MORE_ASSERTS is not enabled by default and nm_assert()
    is stripped away. That is the actual purpose of nm_assert(): it is
    commonly disabled on release builds, while all other assertions are
    enabled.
    
    Note that it is fully supported to build NetworkManager with all kind of
    assertions disabled. However, such a configuration is not much tested
    and I would not recommend it for that reason.
    
    %meson expands to
    
      $ /usr/bin/meson --buildtype=plain --prefix=/usr --libdir=/usr/lib64 --libexecdir=/usr/libexec --bindir=/usr/bin --sbindir=/usr/sbin --includedir=/usr/include --datadir=/usr/share --mandir=/usr/share/man --infodir=/usr/share/info --localedir=/usr/share/locale --sysconfdir=/etc --localstatedir=/var --sharedstatedir=/var/lib --wrap-mode=nodownload --auto-features=enabled -Db_ndebug=true . x86_64-redhat-linux-gnu $OTHER_ARGS
    
    thus passing -DNDEBUG to the meson build. Override that.
    ef338667