• Dan Winship's avatar
    libnm-util, libnm-glib: add versioned deprecation/availability macros · 9c4d86ee
    Dan Winship authored
    Add versioned NM_DEPRECATED_IN_* and NM_AVAILABLE_IN_* macros, and tag
    new/deprecated functions accordingly. (All currently-deprecated
    functions are assumed to have been deprecated in 0.9.10.)
    
    Add NM_VERSION_MIN_REQUIRED and NM_VERSION_MAX_ALLOWED macros which
    can be set to determine which versions will cause warnings.
    
    With the current settings, external consumers of the
    libnm-util/libnm-glib APIs will have MIN_REQUIRED and MAX_ALLOWED both
    set to NM_VERSION_0_9_8 by default, meaning they will get warnings
    about functions added in 0.9.10. NM internally sets
    NM_VERSION_MAX_ALLOWED to NM_VERSION_NEXT_STABLE to ensure that it is
    always allowed to use all APIs.
    9c4d86ee
nm-remote-settings.h 7.09 KB