Commit 3c67a1ec authored by Francesco Giudici's avatar Francesco Giudici

cli: remove version check against NM

When performing NM package upgrade the new version of nmcli will be immediately
available while NM daemon will not, as it would not restart in order to avoid
to disrupt connectivity. This could create issues with tools leveraging
on nmcli output (till reboot). As apart from this case it is very unlikely
that a user can have this nmcli / NM daemon version mismatch situation,
the check could cause more harm than benefit in real user case
scenarios.

https://bugzilla.redhat.com/show_bug.cgi?id=1291785
parent 0589e659
......@@ -207,9 +207,6 @@ do_agent (NmCli *nmc, int argc, char **argv)
nmc->return_value = NMC_RESULT_ERROR_NM_NOT_RUNNING;
return nmc->return_value;
}
/* Compare NM and nmcli versions */
if (!nmc_versions_match (nmc))
return nmc->return_value;
if (argc == 0) {
nmc->return_value = do_agent_all (nmc, 0, NULL);
......
......@@ -11051,9 +11051,6 @@ do_connections (NmCli *nmc, int argc, char **argv)
nmc->return_value = NMC_RESULT_ERROR_NM_NOT_RUNNING;
return nmc->return_value;
}
/* Compare NM and nmcli versions */
if (!nmc_versions_match (nmc))
return nmc->return_value;
/* Get the connection list */
nmc->connections = nm_client_get_connections (nmc->client);
......
......@@ -3670,9 +3670,6 @@ do_devices (NmCli *nmc, int argc, char **argv)
nmc->return_value = NMC_RESULT_ERROR_NM_NOT_RUNNING;
return nmc->return_value;
}
/* Compare NM and nmcli versions */
if (!nmc_versions_match (nmc))
return nmc->return_value;
if (argc == 0) {
if (!nmc_terse_option_check (nmc->print_output, nmc->required_fields, &error))
......
......@@ -345,9 +345,6 @@ show_nm_status (NmCli *nmc, const char *pretty_header_name, const char *print_fl
return FALSE;
}
if (!nmc_versions_match (nmc))
return FALSE;
state = nm_client_get_state (nmc->client);
startup = nm_client_get_startup (nmc->client);
connectivity = nm_client_get_connectivity (nmc->client);
......
......@@ -178,9 +178,6 @@ _nmcli_compl_OPTIONS()
pretty)
_nmcli_array_delete_at words 0
;;
nocheck)
_nmcli_array_delete_at words 0
;;
ask)
_nmcli_array_delete_at words 0
;;
......@@ -804,7 +801,7 @@ _nmcli()
local COMMAND_CONNECTION_ACTIVE=""
HELP_ONLY_AS_FIRST=
local LONG_OPTIONS=(terse pretty mode fields colors escape nocheck ask show-secrets wait version help)
local LONG_OPTIONS=(terse pretty mode fields colors escape ask show-secrets wait version help)
_nmcli_compl_OPTIONS
i=$?
......
......@@ -89,7 +89,6 @@ usage (const char *prog_name)
" -c[olors] auto|yes|no whether to use colors in output\n"
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in values\n"
" -n[ocheck] don't check nmcli and NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for finishing operations\n"
......@@ -254,7 +253,7 @@ parse_command_line (NmCli *nmc, int argc, char **argv)
}
nmc->required_fields = g_strdup (argv[1]);
} else if (matches (opt, "-nocheck") == 0) {
nmc->nocheck_ver = TRUE;
/* ignore for backward compatibility */
} else if (matches (opt, "-ask") == 0) {
nmc->ask = TRUE;
} else if (matches (opt, "-show-secrets") == 0) {
......@@ -545,7 +544,6 @@ nmc_init (NmCli *nmc)
nmc->required_fields = NULL;
nmc->output_data = g_ptr_array_new_full (20, g_free);
memset (&nmc->print_fields, '\0', sizeof (NmcPrintFields));
nmc->nocheck_ver = FALSE;
nmc->ask = FALSE;
nmc->show_secrets = FALSE;
nmc->use_colors = NMC_USE_COLOR_AUTO;
......
......@@ -59,7 +59,7 @@ typedef enum {
/* NetworkManager is not running */
NMC_RESULT_ERROR_NM_NOT_RUNNING = 8,
/* nmcli and NetworkManager versions mismatch */
/* No more used, keep to preserve API */
NMC_RESULT_ERROR_VERSIONS_MISMATCH = 9,
/* Connection/Device/AP not found */
......@@ -152,7 +152,6 @@ typedef struct _NmCli {
char *required_fields; /* Required fields in output: '--fields' option */
GPtrArray *output_data; /* GPtrArray of arrays of NmcOutputField structs - accumulates data for output */
NmcPrintFields print_fields; /* Structure with field indices to print */
gboolean nocheck_ver; /* Don't check nmcli and NM versions: option '--nocheck' */
gboolean ask; /* Ask for missing parameters: option '--ask' */
gboolean show_secrets; /* Whether to display secrets (both input and output): option '--show-secrets' */
gboolean in_editor; /* Whether running the editor - nmcli con edit' */
......
......@@ -1359,48 +1359,3 @@ print_data (NmCli *nmc)
}
}
/*
* Compare versions of nmcli and NM daemon.
* Return: TRUE - the versions match (when only major and minor match, print a warning)
* FALSE - versions mismatch
*/
gboolean
nmc_versions_match (NmCli *nmc)
{
const char *nm_ver = NULL;
const char *dot;
gboolean match = FALSE;
g_return_val_if_fail (nmc != NULL, FALSE);
/* --nocheck option - don't compare the versions */
if (nmc->nocheck_ver)
return TRUE;
nmc->get_client (nmc);
nm_ver = nm_client_get_version (nmc->client);
if (nm_ver) {
if (!strcmp (nm_ver, VERSION))
match = TRUE;
else {
dot = strchr (nm_ver, '.');
if (dot) {
dot = strchr (dot + 1, '.');
if (dot && !strncmp (nm_ver, VERSION, dot-nm_ver)) {
g_printerr (_("Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --nocheck to suppress the warning.\n"),
VERSION, nm_ver);
match = TRUE;
}
}
}
}
if (!match) {
g_string_printf (nmc->return_text, _("Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force execution using --nocheck, but the results are unpredictable."),
VERSION, nm_ver ? nm_ver : _("unknown"));
nmc->return_value = NMC_RESULT_ERROR_VERSIONS_MISMATCH;
}
return match;
}
......@@ -105,6 +105,5 @@ NmcOutputField *nmc_dup_fields_array (NmcOutputField fields[], size_t size, guin
void nmc_empty_output_fields (NmCli *nmc);
void print_required_fields (NmCli *nmc, const NmcOutputField field_values[]);
void print_data (NmCli *nmc);
gboolean nmc_versions_match (NmCli *nmc);
#endif /* NMC_UTILS_H */
......@@ -230,20 +230,6 @@
</listitem>
</varlistentry>
<varlistentry>
<term><group choice='plain'>
<arg choice='plain'><option>-n</option></arg>
<arg choice='plain'><option>--nocheck</option></arg>
</group></term>
<listitem>
<para>This option can be used to force <command>nmcli</command> to skip
checking <command>nmcli</command> and <command>NetworkManager</command>
version compatibility. Use it with care, because using incompatible versions
may produce incorrect results.</para>
</listitem>
</varlistentry>
<varlistentry>
<term><group choice='plain'>
<arg choice='plain'><option>-a</option></arg>
......@@ -2806,14 +2792,6 @@
</listitem>
</varlistentry>
<varlistentry>
<term><errorcode>9</errorcode></term>
<listitem>
<para><command>nmcli</command> and <command>NetworkManager</command>
versions mismatch.</para>
</listitem>
</varlistentry>
<varlistentry>
<term><errorcode>10</errorcode></term>
<listitem>
......
......@@ -4783,8 +4783,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5759,20 +5757,6 @@ msgstr ""
msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -5406,8 +5406,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5434,8 +5432,6 @@ msgstr ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -w[ait] <seconds> set timeout waiting for "
"finishing operations\n"
......@@ -6519,24 +6515,6 @@ msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
"বিকল্প '--terse' ৰ বিশেষ '--fields' বিকল্প মানসমূহ ধাৰ্য্য কৰাৰ প্ৰয়োজন, '%s' নহয়"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
"সতৰ্কবাৰ্তা: nmcli (%s) আৰু NetworkManager (%s) সংস্কৰণসমূহ মিল নাখায়। সতৰ্কবাৰ্তা "
"দবাবলে --nocheck ব্যৱহাৰ কৰক।\n"
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
"ত্ৰুটি: nmcli (%s) আৰু NetworkManager (%s) সংস্কৰণসমূহ মিল নাখায়। --nocheck "
"ব্যৱহাৰ কৰি এক্সিকিউচন বলৱৎ কৰক, কিন্তু ফলাফলসমূহৰ আগজাননী দিব নোৱাৰি।"
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -4757,8 +4757,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5732,20 +5730,6 @@ msgstr ""
msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -4875,8 +4875,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5876,20 +5874,6 @@ msgstr "Опцията „--terse“ изисква указването на
msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr "Опцията „--terse“ изисква конкретни стойности за „--fields“, а не „%s“"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -5408,8 +5408,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5436,8 +5434,6 @@ msgstr ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -w[ait] <seconds> set timeout waiting for "
"finishing operations\n"
......@@ -6518,24 +6514,6 @@ msgstr ""
"'--terse' বিকল্পের ক্ষেত্রে '--fields' বিকল্পের সুনির্দিষ্ট মান উল্লেখ করা আবশ্যক, "
"'%s' ব্যবহার করা যাবে না"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
"সতর্কবার্তা: nmcli (%s) ও NetworkManager-র (%s) সংস্করণে গরমিল। সতর্কবার্তা আড়াল "
"করার জন্য --nocheck ব্যবহার করুন।\n"
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
"ত্রুটি: nmcli (%s) ও NetworkManager-র (%s) সংস্করণে গরমিল। বাধ্যতামূলক ভাবে "
"সঞ্চালন করার জন্য --nocheck ব্যবহার করুন, কিন্তু অপ্রত্যাশিত ফলাফল সৃষ্টি হতে পারে।"
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -4770,8 +4770,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5745,20 +5743,6 @@ msgstr ""
msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -5563,8 +5563,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5594,8 +5592,6 @@ msgstr ""
"sortida\n"
" -e[scape] yes|no separadors de columnes "
"d'escapament als valors\n"
" -n[ocheck] no comprovis les versions de "
"nmcli i de NetworkManager\n"
" -a[sk] demana els paràmetres que "
"faltin\n"
" -s[how-secrets] permet que es mostrin les "
......@@ -6730,24 +6726,6 @@ msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
"L'opció «--terse» requereix valors específics de l'opció «--fields» i no «%s»"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
"Advertiment: les versions del nmcli (%s) i del NetworkManager (%s) no "
"concorden. Useu --nocheck per suprimir l'advertiment.\n"
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
"Error: les versions del nmcli (%s) i del NetworkManager (%s) no concorden. "
"Forceu l'execució usant --nocheck, però els resultats no són predicibles."
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr "Ja està en marxa una sessió d'autenticació."
......
......@@ -4848,8 +4848,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -4875,8 +4873,6 @@ msgstr ""
" -m[ode] tabular|multiline režim výstupu\n"
" -f[ields] <field1,field2,...>|all|common specifikace polí výstupu\n"
" -e[scape] yes|no oddělovače sloupců v hodnotách\n"
" -n[ocheck] nekontrolovat verze programů "
"nmcli a NetworkManager\n"
" -v[ersion] zobrazit verzi programu\n"
" -h[elp] zobrazit tuto nápovědu\n"
"\n"
......@@ -5847,24 +5843,6 @@ msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
"Přepínač „--terse“ vyžaduje určité hodnoty přepínače „--fields“, ne „%s“"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
"Varování: verze programů nmcli (%s) a NetworkManager (%s) si neodpovídají. "
"Pro potlačení varování použijte --nocheck.\n"
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
"Varování: verze programů nmcli (%s) a NetworkManager (%s) si neodpovídají. "
"Pro spuštění použijte --nocheck, ale může dojít k nepředvídatelnému chování."
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -4866,8 +4866,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5864,20 +5862,6 @@ msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
"Tilvalg '--terse' kræver specifikke tilvalgsværdier for '--fields', ikke '%s'"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -5609,8 +5609,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5638,8 +5636,6 @@ msgstr ""
" -f[ields] <Feld1,Feld2, …>|all|common Ausgabefelder angeben\n"
" -e[scape] yes|no Escape-Spaltenseparator in "
"Werten\n"
" -n[ocheck] Nicht die Versionen von nmcli "
"und NetworkManager prüfen\n"
" -a[sk] Nach fehlenden Parametern "
"fragen\n"
" -s[how-secrets] Passwörter anzeigen\n"
......@@ -6761,25 +6757,6 @@ msgstr "Option »--terse« benötigt die Angabe von »--fields«"
msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr "Option »--terse« benötigt bestimmte »--fields«-Werte, nicht »%s«"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
"Warnung: Die Versionen von nmcli (%s) und NetworkManager (%s) stimmen nicht "
"überein. Verwenden Sie »--nocheck«, um diese Warnung zu unterdrücken.\n"
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
"Fehler: Die Versionen von nmcli (%s) und NetworkManager (%s) stimmen nicht "
"überein. Eine Ausführung kann mit »--nocheck« erzwungen werden, aber die "
"Resultate sind unvorhersehbar."
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -4779,8 +4779,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5755,20 +5753,6 @@ msgstr ""
msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -5495,8 +5495,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5523,8 +5521,6 @@ msgstr ""
" -f[ields] <field1,field2,...>|all|common ορισμός πεδίων εξόδου\n"
" -e[scape] yes|no διαφυγή διαχωριστικών στηλών σε "
"τιμές\n"
" -n[ocheck] να μην ελέγχονται οι εκδόσεις "
"nmcli και NetworkManager\n"
" -a[sk] ερώτηση για ελλείπουσες "
"παραμέτρους\n"
" -w[ait] <seconds> ορισμός χρόνου λήξης αναμονής "
......@@ -6627,26 +6623,6 @@ msgstr ""
"Η επιλογή '--terse' απαιτεί να καθορισθούν συγκεκριμένες τιμές της επιλογής "
"'--fields', όχι '%s'"
#: ../clients/cli/utils.c:1390
#, c-format
msgid ""
"Warning: nmcli (%s) and NetworkManager (%s) versions don't match. Use --"
"nocheck to suppress the warning.\n"
msgstr ""
"Προειδοποίηση: δεν ταιριάζουν οι εκδόσεις του nmcli (%s) και του "
"NetworkManager (%s) . Χρησιμοποιείστε --nocheck για να εξαφανίσετε την "
"προειδοποίηση.\n"
#: ../clients/cli/utils.c:1399
#, c-format
msgid ""
"Error: nmcli (%s) and NetworkManager (%s) versions don't match. Force "
"execution using --nocheck, but the results are unpredictable."
msgstr ""
"Σφάλμα: δεν ταιριάζουν οι εκδόσεις του nmcli (%s) και του NetworkManager "
"(%s) . Κάντε εξαναγκασμένη εκτέλεση χρησιμοποιώντας --nocheck, αλλά τα "
"αποτελέσματα είναι απρόβλεπτα."
#: ../clients/common/nm-polkit-listener.c:212
msgid "An authentication session is already underway."
msgstr ""
......
......@@ -4805,8 +4805,6 @@ msgid ""
" -f[ields] <field1,field2,...>|all|common specify fields to output\n"
" -e[scape] yes|no escape columns separators in "
"values\n"
" -n[ocheck] don't check nmcli and "
"NetworkManager versions\n"
" -a[sk] ask for missing parameters\n"
" -s[how-secrets] allow displaying passwords\n"
" -w[ait] <seconds> set timeout waiting for "
......@@ -5781,20 +5779,6 @@ msgstr ""
msgid "Option '--terse' requires specific '--fields' option values , not '%s'"
msgstr ""
#: ../clients/cli/utils.c:1390