Commit ab165db6 authored by Niels De Graef's avatar Niels De Graef Committed by Nicolas Dufresne

meson: Bump minimal GLib version to 2.44

This means we can use some newer features and get rid of some boilerplate code using the G_DECLARE_* macros.

As discussed on IRC, 2.44 is old enough by now to start depending on it.
parent 59dd2af6
......@@ -269,7 +269,7 @@ AG_GST_CHECK_FUNCTION
dnl *** checks for dependency libraries ***
dnl GLib
GLIB_REQ=2.40.0
GLIB_REQ=2.44.0
AG_GST_GLIB_CHECK([$GLIB_REQ])
ORC_CHECK([0.4.24])
......
......@@ -19,7 +19,7 @@ gst_version_is_dev = gst_version_minor % 2 == 1 and gst_version_micro < 90
have_cxx = add_languages('cpp', required : false)
have_objc = add_languages('objc', required : false)
glib_req = '>= 2.40.0'
glib_req = '>= 2.44.0'
orc_req = '>= 0.4.24'
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment