Commit 2bef3f74 authored by Jan Schmidt's avatar Jan Schmidt Committed by Tim-Philipp Müller

pkg-config: Don't generate and install pkg-config with relative paths

Don't put relative paths in pkg-config files, including uninstalled
ones. For those, use @abs_topbuilddir@ and @abs_topsrcdir@ as we
do elsewhere.

Remove libraries= directives, which doesn't seem to be a pkg-config
variable that actually exists, but has been in all our pkg-config
files for as long as they've existed.
parent e03e983e
prefix=
exec_prefix=
libdir=${pcfiledir}/../gst-libs/gst/gl
includedir=${pcfiledir}/../gst-libs
pluginsdir=${pcfiledir}/..
libdir=
includedir=@abs_top_builddir@/gst-libs
girdir=@abs_top_builddir@/gst-libs/gst/base
typelibdir=@abs_top_builddir@/gst-libs/gst/base
Name: GStreamer OpenGL Plugins Libraries, Uninstalled
Description: Streaming media framework, OpenGL plugins libraries, uninstalled
Version: @VERSION@
Requires: gstreamer-@GST_API_VERSION@
Requires: gstreamer-base-@GST_API_VERSION@ gstreamer-@GST_API_VERSION@
Libs: -L${libdir} ${libdir}/libgstgl-@GST_API_VERSION@.la @GL_LIBS@
Cflags: -I${includedir} -I@srcdir@/.. @GL_CFLAGS@
libraries=gl
Libs: @abs_top_builddir@/gst-libs/gst/gl/libgstgl-@GST_API_VERSION@.la
Cflags: -I@abs_top_srcdir@/gst-libs -I@abs_top_builddir@/gst-libs
......@@ -6,8 +6,8 @@ pluginsdir=@libdir@/gstreamer-@GST_API_VERSION@
Name: GStreamer OpenGL Plugins Libraries
Description: Streaming media framework, OpenGL plugins libraries
Requires: gstreamer-@GST_API_VERSION@ gstreamer-base-@GST_API_VERSION@
Version: @VERSION@
Libs: -L${libdir} -lgstgl-@GST_API_VERSION@ @GL_LIBS@
Cflags: -I${includedir} -I${libdir}/gstreamer-@GST_API_VERSION@/include @GL_CFLAGS@
Requires: gstreamer-base-@GST_API_VERSION@ gstreamer-@GST_API_VERSION@
Libs: -L${libdir} -lgstgl-@GST_API_VERSION@ @GL_LIBS@
Cflags: -I${includedir} @GL_CFLAGS@
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment