1. 03 May, 2014 1 commit
  2. 24 Sep, 2013 1 commit
  3. 19 Sep, 2013 1 commit
  4. 28 Aug, 2013 1 commit
  5. 29 Jul, 2013 1 commit
  6. 11 Jul, 2013 1 commit
  7. 05 Jun, 2013 1 commit
  8. 25 Oct, 2012 1 commit
  9. 07 Oct, 2012 1 commit
  10. 14 Sep, 2012 1 commit
  11. 07 Jun, 2012 1 commit
  12. 13 May, 2012 1 commit
  13. 12 Apr, 2012 1 commit
  14. 22 Mar, 2012 1 commit
  15. 17 Feb, 2012 1 commit
  16. 10 May, 2011 1 commit
    • Tim-Philipp Müller's avatar
      Release 0.10.18 · 9009d82d
      Tim-Philipp Müller authored
      Highlights:
      
        - x264enc: allow changing bitrate and quantizers dynamically at runtime
        - x264enc: proxy downstream caps restrictions upstream via get_caps()
        - lamemp3enc: proxy downstream rate/channels restrictions upstream via get_caps()
        - mad: allow build without libid3tag (which isn't really needed anyway)
        - many other fixes and improvements
      9009d82d
  17. 21 Jan, 2011 1 commit
  18. 02 Sep, 2010 1 commit
  19. 30 May, 2010 1 commit
  20. 06 Mar, 2010 1 commit
  21. 21 Oct, 2009 1 commit
  22. 15 Oct, 2009 1 commit
  23. 12 Oct, 2009 1 commit
  24. 18 Jun, 2009 1 commit
  25. 21 Mar, 2009 1 commit
  26. 08 Jan, 2009 1 commit
    • Yves Lefebvre's avatar
      gst/mpegstream/: Fix some caps leaks. Fixes bug #564885. · f4567b2c
      Yves Lefebvre authored and Sebastian Dröge's avatar Sebastian Dröge committed
      Original commit message from CVS:
      Patch by: Yves Lefebvre <ivanohe at abacom dot com>
      * gst/mpegstream/gstdvddemux.c: (gst_dvd_demux_get_video_stream),
      (gst_dvd_demux_get_audio_stream),
      (gst_dvd_demux_get_subpicture_stream), (gst_dvd_demux_reset):
      * gst/mpegstream/gstmpegdemux.c: (gst_mpeg_demux_init_stream),
      (gst_mpeg_demux_get_video_stream),
      (gst_mpeg_demux_get_audio_stream), (gst_mpeg_demux_reset):
      * gst/mpegstream/gstmpegparse.c: (gst_mpeg_parse_chain):
      Fix some caps leaks. Fixes bug #564885.
      f4567b2c
  27. 02 Jan, 2009 1 commit
  28. 13 Dec, 2008 3 commits
  29. 10 Dec, 2008 1 commit
    • Tim-Philipp Müller's avatar
      gst/mpegaudioparse/gstmpegaudioparse.*: Do an initial class_ref on an internal... · 8c6bcd67
      Tim-Philipp Müller authored
      gst/mpegaudioparse/gstmpegaudioparse.*: Do an initial class_ref on an internal enum type from within the class_init f...
      
      Original commit message from CVS:
      * gst/mpegaudioparse/gstmpegaudioparse.c: (channel_mode_class),
      (GST_TYPE_MP3_CHANNEL_MODE), (mp3_type_frame_length_from_header),
      (gst_mp3parse_emit_frame), (mp3parse_get_query_types):
      * gst/mpegaudioparse/gstmpegaudioparse.h:
      Do an initial class_ref on an internal enum type from within the
      class_init function so that there aren't any issues when multiple
      mp3parse elements are started in separate threads at the same
      time. (Why we use an enum type here if the tag is registered as
      a string type, I don't know). Also remove custom UNUSED macro
      and use GLib's instead.
      8c6bcd67
  30. 04 Dec, 2008 2 commits
  31. 01 Dec, 2008 1 commit
    • Sebastian Dröge's avatar
      ext/mpeg2dec/gstmpeg2dec.c: Last change introduced a regression that made... · 81599fc7
      Sebastian Dröge authored
      ext/mpeg2dec/gstmpeg2dec.c: Last change introduced a regression that made mpeg2dec handle some 4:2:2 videos as 4:4:4....
      
      Original commit message from CVS:
      * ext/mpeg2dec/gstmpeg2dec.c: (gst_mpeg2dec_negotiate_format):
      Last change introduced a regression that made mpeg2dec handle
      some 4:2:2 videos as 4:4:4. Fixes bug #562086.
      81599fc7
  32. 29 Nov, 2008 1 commit
    • Sebastian Dröge's avatar
      Require gettext 0.17 because older versions don't mix with libtool 2.2. At... · bc794219
      Sebastian Dröge authored
      Require gettext 0.17 because older versions don't mix with libtool 2.2. At build time an older gettext version will s...
      
      Original commit message from CVS:
      Patch by: Cygwin Ports maintainer
      <yselkowitz at users dot sourceforge dot net>
      * autogen.sh:
      * configure.ac:
      Require gettext 0.17 because older versions don't mix with libtool
      2.2. At build time an older gettext version will still work.
      Fixes bug #556091.
      bc794219
  33. 25 Nov, 2008 1 commit
  34. 24 Nov, 2008 1 commit
  35. 20 Nov, 2008 2 commits
  36. 19 Nov, 2008 1 commit