Commit 8862ca27 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller 🐠

Release 1.12.5

parent 208ce17a
=== release 1.12.5 ===
2018-03-28 14:23:55 +0100 Tim-Philipp Müller <tim@centricular.com>
* ChangeLog:
* NEWS:
* RELEASE:
* configure.ac:
* gst-plugins-ugly.doap:
* meson.build:
Release 1.12.5
2018-03-28 14:23:55 +0100 Tim-Philipp Müller <tim@centricular.com>
* docs/plugins/inspect/plugin-a52dec.xml:
* docs/plugins/inspect/plugin-amrnb.xml:
* docs/plugins/inspect/plugin-amrwbdec.xml:
* docs/plugins/inspect/plugin-asf.xml:
* docs/plugins/inspect/plugin-cdio.xml:
* docs/plugins/inspect/plugin-dvdlpcmdec.xml:
* docs/plugins/inspect/plugin-dvdread.xml:
* docs/plugins/inspect/plugin-dvdsub.xml:
* docs/plugins/inspect/plugin-lame.xml:
* docs/plugins/inspect/plugin-mpeg2dec.xml:
* docs/plugins/inspect/plugin-mpg123.xml:
* docs/plugins/inspect/plugin-realmedia.xml:
* docs/plugins/inspect/plugin-siddec.xml:
* docs/plugins/inspect/plugin-twolame.xml:
* docs/plugins/inspect/plugin-x264.xml:
* docs/plugins/inspect/plugin-xingmux.xml:
Update docs
2018-02-28 10:07:13 +0000 Tim-Philipp Müller <tim@centricular.com>
* ext/x264/gstx264enc.c:
x264enc: fix build with newer x264 with support for multiple bit depths
libx264 used to be built for one specific bit depth, and if we
wanted to support multiple bit depths we would have to dynamically
load the right .so from different paths. That has changed now, and
libx264 can include support for multiple depths in the same lib,
so we don't need to do the dlopen() dance any more. We'll keep
the vtable stuff around until we can drop support for older x264.
gstx264enc.c:2927:36: error: ‘x264_bit_depth’ undeclared
https://bugzilla.gnome.org/show_bug.cgi?id=792111
2018-01-03 16:02:08 +0100 Edward Hervey <edward@centricular.com>
* ext/amrnb/amrnbdec.c:
amrnbdec: Don't use g_return_*_if_fail() on data parsing
Those functions can be disabled. Instead just use the (existing)
function.
CID #1427121
2018-01-03 16:02:08 +0100 Edward Hervey <edward@centricular.com>
* ext/amrwbdec/amrwbdec.c:
amrwbdec: Don't use g_return_*_if_fail() on data parsing
Those functions can be disabled. Instead just use the (existing)
function.
CID #1427093
=== release 1.12.4 ===
2017-12-07 Sebastian Dröge <slomo@coaxion.net>
2017-12-07 20:22:27 +0200 Sebastian Dröge <sebastian@centricular.com>
* ChangeLog:
* NEWS:
* RELEASE:
* configure.ac:
releasing 1.12.4
* docs/plugins/inspect/plugin-a52dec.xml:
* docs/plugins/inspect/plugin-amrnb.xml:
* docs/plugins/inspect/plugin-amrwbdec.xml:
* docs/plugins/inspect/plugin-asf.xml:
* docs/plugins/inspect/plugin-cdio.xml:
* docs/plugins/inspect/plugin-dvdlpcmdec.xml:
* docs/plugins/inspect/plugin-dvdread.xml:
* docs/plugins/inspect/plugin-dvdsub.xml:
* docs/plugins/inspect/plugin-lame.xml:
* docs/plugins/inspect/plugin-mpeg2dec.xml:
* docs/plugins/inspect/plugin-mpg123.xml:
* docs/plugins/inspect/plugin-realmedia.xml:
* docs/plugins/inspect/plugin-siddec.xml:
* docs/plugins/inspect/plugin-twolame.xml:
* docs/plugins/inspect/plugin-x264.xml:
* docs/plugins/inspect/plugin-xingmux.xml:
* gst-plugins-ugly.doap:
* meson.build:
Release 1.12.4
2017-12-07 19:27:07 +0200 Sebastian Dröge <sebastian@centricular.com>
* po/af.po:
* po/az.po:
* po/bg.po:
* po/ca.po:
* po/cs.po:
* po/da.po:
* po/de.po:
* po/el.po:
* po/en_GB.po:
* po/eo.po:
* po/es.po:
* po/eu.po:
* po/fi.po:
* po/fr.po:
* po/fur.po:
* po/gl.po:
* po/hr.po:
* po/hu.po:
* po/id.po:
* po/it.po:
* po/ja.po:
* po/lt.po:
* po/lv.po:
* po/ms.po:
* po/mt.po:
* po/nb.po:
* po/nl.po:
* po/or.po:
* po/pl.po:
* po/pt_BR.po:
* po/ro.po:
* po/ru.po:
* po/sk.po:
* po/sl.po:
* po/sq.po:
* po/sr.po:
* po/sv.po:
* po/tr.po:
* po/uk.po:
* po/vi.po:
* po/zh_CN.po:
Update .po files
2017-12-07 19:08:11 +0200 Sebastian Dröge <sebastian@centricular.com>
......
# GStreamer 1.12 Release Notes
GStreamer 1.12.0 was originally released on 4th May 2017.
The latest bug-fix release in the 1.12 series is [1.12.4](#1.12.4) and was
released on 7 December 2017.
The GStreamer team is proud to announce a new major feature release in the
stable 1.x API series of your favourite cross-platform multimedia framework!
As always, this release is again packed with new features, bug fixes and other
improvements.
The latest bug-fix release in the 1.12 series is [1.12.5](#1.12.5) and was
released on 28 March 2018.
See [https://gstreamer.freedesktop.org/releases/1.12/][latest] for the latest
version of this document.
*Last updated: Thursday 7 December 2017, 16:30 UTC [(log)][gitlog]*
*Last updated: Wednesday 28 March 2018, 10:00 UTC [(log)][gitlog]*
[latest]: https://gstreamer.freedesktop.org/releases/1.12/
[gitlog]: https://cgit.freedesktop.org/gstreamer/www/log/src/htdocs/releases/1.12/release-notes-1.12.md
......@@ -810,6 +804,8 @@ GIT logs or ChangeLogs of the particular modules.
[buglist-1.12.3]: https://bugzilla.gnome.org/buglist.cgi?bug_status=RESOLVED&bug_status=VERIFIED&classification=Platform&limit=0&list_id=248880&order=bug_id&product=GStreamer&query_format=advanced&resolution=FIXED&target_milestone=1.12.3
<a name="1.12.4"></a>
### 1.12.4
The fourth 1.12 bug-fix release (1.12.4) was released on 7 December 2017.
......@@ -842,6 +838,54 @@ GIT logs or ChangeLogs of the particular modules.
[buglist-1.12.4]: https://bugzilla.gnome.org/buglist.cgi?bug_status=RESOLVED&bug_status=VERIFIED&classification=Platform&limit=0&list_id=270310&order=bug_id&product=GStreamer&query_format=advanced&resolution=FIXED&target_milestone=1.12.4
<a name="1.12.5"></a>
### 1.12.5
The fifth (and likely last) 1.12 bug-fix release (1.12.5) was released on
28 March 2018. This release only contains bugfixes and it should be safe to
update from 1.12.x.
The 1.12 series has now been superseded by the 1.14 stable release series,
and users should upgrade at their earliest convenience.
#### Bugs fixed in 1.12.5
- pad: fix some stream deactivation deadlocks/races
- registrychunks: don't read from unaligned memory when loading registry
- ptp: fix build failure with #undef USE_MEASUREMENT_FILTERING
- downloadbuffer: Don't hold the mutex while posting the download-complete message
- playbin3: Fix accessing invalid index in GstStream when received select-stream event
- id3v2: re-fix handling of ID3 v2.4 tags with extended headers
- audio: fix handling of U32BE format
- videodecoder: Reset QoS time after pushing segment. This fixes playbin gapless playback with videos.
- subparse: push out of last chunk of text if last line has no newline
- aacparse: When parsing raw input, accept frames of any size. This fixes handling of encoded silence.
- splitmuxsrc: Improve not-linked handling.
- rtspsrc: also proxy multicast-iface property to RTCP udpsrc
- flacdec: flush flac decoder on lost sync, so that it can re-sync.
- matroskamux: Only mark new clusters as keyframe if they start on a keyframe or we're muxing only audio
- matroskamux: Clip maximum cluster duration to the maximum possible value
- h264parse: reset internal 'state' variable properly
- x264enc: fix build with newer x264 with support for multiple bit depths
- x265enc: Fix tagging of keyframes on output buffers
- glimagesink: Correct PAR in output caps when transforming
- vtdec: destroy and create the GL context on start()/stop(), fixing a refcount loop
- player: fix criticals when reading info/track properties that are NULL
- lv2: fix inverted boolean properties
- rtponviftimestamp: fix state change function init/reset, fixing memory corruption or leaks on shutdown
- libav: some build issues fixes
- rtsp-server: Place netaddress meta on packets received via TCP. Fixes keep-alive via RTCP in TCP interleaved mode.
- rtsp-server: gi annotation fixes
- Various fixes for memory leaks, deadlocks and crashes in all modules
- ... and many, many more!
For a full list of bugfixes see [Bugzilla][buglist-1.12.5]. Note that this is
not the full list of changes. For the full list of changes please refer to the
GIT logs or ChangeLogs of the particular modules.
[buglist-1.12.5]: https://bugzilla.gnome.org/buglist.cgi?bug_status=RESOLVED&bug_status=VERIFIED&classification=Platform&limit=0&list_id=270310&order=bug_id&product=GStreamer&query_format=advanced&resolution=FIXED&target_milestone=1.12.5
## Known Issues
- The `webrtcdsp` element is currently not shipped as part of the Windows
......@@ -851,18 +895,14 @@ GIT logs or ChangeLogs of the particular modules.
## Schedule for 1.14
Our next major feature release will be 1.14, and 1.13 will be the unstable
development version leading up to the stable 1.14 release. The development
of 1.13/1.14 will happen in the git master branch.
[GStreamer 1.14.0][release-1.14] was released on 19 March 2018 and supersedes
the 1.12.x series.
The plan for the 1.14 development cycle is yet to be confirmed, but it is
expected that feature freeze will be around early December 2017
followed by several 1.13 pre-releases and the new 1.14 stable release
in late December or some time in January.
1.14 will be backwards-compatible to the stable 1.12, 1.10, 1.8, 1.6, 1.4,
It is backwards-compatible to the stable 1.12, 1.10, 1.8, 1.6, 1.4,
1.2 and 1.0 release series.
[release-1.14]: https://gstreamer.freedesktop.org/releases/1.14/
- - -
*These release notes have been prepared by Olivier Crête, Sebastian Dröge,
......
This is GStreamer gst-plugins-ugly 1.12.5.
Release notes for GStreamer Ugly Plugins 1.12.4
The GStreamer team is proud to announce the fourth bugfix release in the stable
The GStreamer team is pleased to announce the fifth bugfix release in the stable
1.12 release series of your favourite cross-platform multimedia framework!
This release only contains bugfixes and it is safe to update from 1.12.x. For a
full list of bugfixes see Bugzilla.
full list of bugfixes see Bugzilla and the release notes.
See /releases/1.12/ for the full release notes.
The 1.12 stable series is now superseded by the 1.14 stable series, and 1.12.5
will likely be the last bugfix release in the 1.12 series.
Full release notes can be found at:
"When you have to shoot, shoot. Don't talk."
https://gstreamer.freedesktop.org/releases/1.12/#1.12.5
Binaries for Android, iOS, Mac OS X and Windows will be provided shortly
after the release.
There are times when the world needs a color between black and white.
Quality code to match the good's, but two-timing, backstabbing and ready to
sell your freedom down the river. These plugins might have a patent noose
around their neck, or a lock-up license, or any other problem that makes you
think twice about shipping them.
This module will not be very useful by itself and should be used in conjunction
with other GStreamer modules for a complete multimedia experience.
- gstreamer: provides the core GStreamer libraries and some generic plugins
We don't call them ugly because we like them less. Does a mother love her
son less because he's not as pretty as the other ones ? No - she commends
him on his great personality. These plugins are the life of the party.
And we'll still step in and set them straight if you report any unacceptable
behaviour - because there are two kinds of people in the world, my friend:
those with a rope around their neck and the people who do the cutting.
- gst-plugins-base: a basic set of well-supported plugins and additional
media-specific GStreamer helper libraries for audio,
video, rtsp, rtp, tags, OpenGL, etc.
- gst-plugins-good: a set of well-supported plugins under our preferred
license
This module contains a set of plugins that have good quality and correct
functionality, but distributing them might pose problems. The license
on either the plugins or the supporting libraries might not be how we'd
like. The code might be widely known to present patent problems.
Distributors should check if they want/can ship these plugins.
- gst-plugins-ugly: a set of well-supported plugins which might pose
problems for distributors
- gst-plugins-bad: a set of plugins of varying quality that have not made
their way into one of core/base/good/ugly yet, for one
reason or another. Many of these are are production quality
elements, but may still be missing documentation or unit
tests; others haven't passed the rigorous quality testing
we expect yet.
Other modules containing plugins are:
- gst-libav: a set of codecs plugins based on the ffmpeg library. This is
where you can find audio and video decoders and encoders
for a wide variety of formats including H.264, AAC, etc.
- gstreamer-vaapi: hardware-accelerated video decoding and encoding using
VA-API on Linux. Primarily for Intel graphics hardware.
gst-plugins-base
contains a basic set of well-supported plugins
gst-plugins-good
contains a set of well-supported plugins under our preferred license
gst-plugins-bad
contains a set of less supported plugins that haven't passed the
rigorous quality testing we expect, or are still missing documentation
and/or unit tests
gst-libav
contains a set of codecs plugins based on libav (formerly gst-ffmpeg)
- gst-omx: hardware-accelerated video decoding and encoding, primarily for
embedded Linux systems that provide an OpenMax
implementation layer such as the Raspberry Pi.
- gst-rtsp-server: library to serve files or streaming pipelines via RTSP
Bugs fixed in this release
* 791301 : cdio: Fails to build with cdio 1.0
- gst-editing-services: library an plugins for non-linear editing
==== Download ====
You can find source releases of gst-plugins-ugly in the download
directory: https://gstreamer.freedesktop.org/src/gst-plugins-ugly/
You can find source releases of gstreamer in the download
directory: https://gstreamer.freedesktop.org/src/gstreamer/
The git repository and details how to clone it can be found at
http://cgit.freedesktop.org/gstreamer/gst-plugins-ugly/
https://cgit.freedesktop.org/gstreamer/gstreamer/
==== Homepage ====
......@@ -74,7 +68,7 @@ The project's website is https://gstreamer.freedesktop.org/
==== Support and Bugs ====
We use GNOME's bugzilla for bug reports and feature requests:
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer
https://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer
Please submit patches via bugzilla as well.
......@@ -90,12 +84,3 @@ from there (see link above).
Interested developers of the core library, plugins, and applications should
subscribe to the gstreamer-devel list.
Contributors to this release
* Deepak Srivastava
* Ponnam Srinivas
* Satya Prakash Gupta
* Sebastian Dröge
 
\ No newline at end of file
......@@ -5,7 +5,7 @@ dnl please read gstreamer/docs/random/autotools before changing this file
dnl initialize autoconf
dnl releases only do -Wall, cvs and prerelease does -Werror too
dnl use a three digit version number for releases, and four for cvs/prerelease
AC_INIT([GStreamer Ugly Plug-ins],[1.12.4],[http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer],[gst-plugins-ugly])
AC_INIT([GStreamer Ugly Plug-ins],[1.12.5],[http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer],[gst-plugins-ugly])
AG_GST_INIT
......@@ -42,7 +42,7 @@ AC_SUBST(GST_API_VERSION)
AC_DEFINE_UNQUOTED(GST_API_VERSION, "$GST_API_VERSION",
[GStreamer API Version])
AS_LIBTOOL(GST, 1204, 0, 1204)
AS_LIBTOOL(GST, 1205, 0, 1205)
dnl *** required versions of GStreamer stuff ***
GST_REQ=1.12.0
......
......@@ -31,7 +31,17 @@ might be widely known to present patent problems.
<location rdf:resource="git://anongit.freedesktop.org/gstreamer/gst-plugins-ugly"/>
<browse rdf:resource="http://cgit.freedesktop.org/gstreamer/gst-plugins-ugly"/>
</GitRepository>
</repository>
</repository>
<release>
<Version>
<revision>1.12.5</revision>
<branch>1.12</branch>
<name></name>
<created>2018-03-28</created>
<file-release rdf:resource="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-1.12.5.tar.xz" />
</Version>
</release>
<release>
<Version>
......
project('gst-plugins-ugly', 'c',
version : '1.12.4',
version : '1.12.5',
meson_version : '>= 0.36.0',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment