Commit 534819a1 authored by Sebastian Dröge's avatar Sebastian Dröge 🍵
Browse files

Release 1.10.0

parent a5300438
=== release 1.10.0 ===
2016-11-01 Sebastian Dröge <slomo@coaxion.net>
* configure.ac:
releasing 1.10.0
2016-11-01 17:43:01 +0200 Sebastian Dröge <sebastian@centricular.com>
* po/id.po:
* po/sv.po:
po: Update translations
2016-10-25 08:54:52 -0700 Scott D Phillips <scott.d.phillips@intel.com>
* meson.build:
* tests/meson.build:
meson: Don't depend on gstreamer-check-1.0 on windows
https://bugzilla.gnome.org/show_bug.cgi?id=773114
2016-10-25 10:51:08 +0530 Nirbheek Chauhan <nirbheek@centricular.com>
* meson.build:
* tests/check/meson.build:
* tests/meson.build:
Revert "meson: move gstreamer-check-1.0 dependency to tests/check"
This reverts commit 0555c09607e548b6c45d029ab31dbb3042195ae3.
Does not actually work. See:
https://bugzilla.gnome.org/show_bug.cgi?id=773114#c31
2016-10-24 00:35:23 +0100 Tim-Philipp Müller <tim@centricular.com>
* tests/check/meson.build:
meson: fix build outside of gst-all
2016-10-21 00:47:14 -0700 Scott D Phillips <scott.d.phillips@intel.com>
* meson.build:
* tests/check/meson.build:
* tests/meson.build:
meson: move gstreamer-check-1.0 dependency to tests/check
https://bugzilla.gnome.org/show_bug.cgi?id=773114
2016-10-15 22:20:05 +0530 Nirbheek Chauhan <nirbheek@centricular.com>
* meson.build:
meson: Don't set c_std to gnu99
Use the default for each compiler on every platform instead. This
improves our compatibility with compilers that don't have gnu99 as
a c_std.
2016-10-04 18:06:09 -0300 Thibault Saunier <thibault.saunier@osg.samsung.com>
* meson.build:
* tests/check/getpluginsdir:
* tests/check/meson.build:
meson: Make use of new environment object and set plugin path to builddir
Workaround source_root being the root directory of all projects
in the subproject case and remove now unneeded getpluginsdir
Bump meson requirement to 0.35
2016-09-30 11:35:40 -0300 Thibault Saunier <thibault.saunier@osg.samsung.com>
* hooks/pre-commit.hook:
* meson.build:
* tests/check/getpluginsdir:
meson: Setup pre commit hook and fix getpluginsdir for standalone case
2016-09-30 11:41:28 +0100 Tim-Philipp Müller <tim@centricular.com>
* meson.build:
meson: update version
=== release 1.9.90 ===
 
2016-09-30 Sebastian Dröge <slomo@coaxion.net>
2016-09-30 13:03:26 +0300 Sebastian Dröge <sebastian@centricular.com>
 
* ChangeLog:
* NEWS:
* RELEASE:
* configure.ac:
releasing 1.9.90
* docs/plugins/inspect/plugin-a52dec.xml:
* docs/plugins/inspect/plugin-amrnb.xml:
* docs/plugins/inspect/plugin-amrwbdec.xml:
* docs/plugins/inspect/plugin-asf.xml:
* docs/plugins/inspect/plugin-cdio.xml:
* docs/plugins/inspect/plugin-dvdlpcmdec.xml:
* docs/plugins/inspect/plugin-dvdread.xml:
* docs/plugins/inspect/plugin-dvdsub.xml:
* docs/plugins/inspect/plugin-lame.xml:
* docs/plugins/inspect/plugin-mad.xml:
* docs/plugins/inspect/plugin-mpeg2dec.xml:
* docs/plugins/inspect/plugin-mpg123.xml:
* docs/plugins/inspect/plugin-realmedia.xml:
* docs/plugins/inspect/plugin-siddec.xml:
* docs/plugins/inspect/plugin-twolame.xml:
* docs/plugins/inspect/plugin-x264.xml:
* docs/plugins/inspect/plugin-xingmux.xml:
* gst-plugins-ugly.doap:
* win32/common/config.h:
Release 1.9.90
2016-09-30 12:23:17 +0300 Sebastian Dröge <sebastian@centricular.com>
* po/af.po:
* po/az.po:
* po/bg.po:
* po/ca.po:
* po/cs.po:
* po/da.po:
* po/de.po:
* po/el.po:
* po/en_GB.po:
* po/eo.po:
* po/es.po:
* po/eu.po:
* po/fi.po:
* po/fr.po:
* po/gl.po:
* po/hr.po:
* po/hu.po:
* po/id.po:
* po/it.po:
* po/ja.po:
* po/lt.po:
* po/lv.po:
* po/ms.po:
* po/mt.po:
* po/nb.po:
* po/nl.po:
* po/or.po:
* po/pl.po:
* po/pt_BR.po:
* po/ro.po:
* po/ru.po:
* po/sk.po:
* po/sl.po:
* po/sq.po:
* po/sr.po:
* po/sv.po:
* po/tr.po:
* po/uk.po:
* po/vi.po:
* po/zh_CN.po:
Update .po files
 
2016-09-30 11:44:22 +0300 Sebastian Dröge <sebastian@centricular.com>
 
......
This diff is collapsed.
Release notes for GStreamer Ugly Plugins 1.9.90
Release notes for GStreamer Ugly Plugins 1.10.0
The GStreamer team is pleased to announce the first release candidate of the
stable 1.10 release series. The 1.10 release series is adding new features on
top of the 1.0, 1.2, 1.4, 1.6 and 1.8 series and is part of the API and
ABI-stable 1.x release series of the GStreamer multimedia framework.
The GStreamer team is pleased to announce the first release of the new stable
1.10 release series. The 1.10 release series is adding new features on top of
the 1.0, 1.2, 1.4, 1.6 and 1.8 series and is part of the API and ABI-stable 1.x
release series of the GStreamer multimedia framework.
Binaries for Android, iOS, Mac OS X and Windows will be provided in the next days.
Binaries for Android, iOS, Mac OS X and Windows will be provided shortly after
the source release by the GStreamer project during the stable 1.10 release
series.
"When you have to shoot, shoot. Don't talk."
......@@ -89,7 +90,8 @@ subscribe to the gstreamer-devel list.
Contributors to this release
* Jan Schmidt
* Nirbheek Chauhan
* Scott D Phillips
* Sebastian Dröge
* Thibault Saunier
* Tim-Philipp Müller
......
......@@ -5,7 +5,7 @@ dnl please read gstreamer/docs/random/autotools before changing this file
dnl initialize autoconf
dnl releases only do -Wall, cvs and prerelease does -Werror too
dnl use a three digit version number for releases, and four for cvs/prerelease
AC_INIT([GStreamer Ugly Plug-ins],[1.9.90],[http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer],[gst-plugins-ugly])
AC_INIT([GStreamer Ugly Plug-ins],[1.10.0],[http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer],[gst-plugins-ugly])
AG_GST_INIT
......@@ -42,11 +42,11 @@ AC_SUBST(GST_API_VERSION)
AC_DEFINE_UNQUOTED(GST_API_VERSION, "$GST_API_VERSION",
[GStreamer API Version])
AS_LIBTOOL(GST, 990, 0, 990)
AS_LIBTOOL(GST, 1000, 0, 1000)
dnl *** required versions of GStreamer stuff ***
GST_REQ=1.9.90
GSTPB_REQ=1.9.90
GST_REQ=1.10.0
GSTPB_REQ=1.10.0
dnl *** autotools stuff ****
......
......@@ -3,7 +3,7 @@
<description>Decodes ATSC A/52 encoded audio streams</description>
<filename>../../ext/a52dec/.libs/libgsta52dec.so</filename>
<basename>libgsta52dec.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>GPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Adaptive Multi-Rate Narrow-Band</description>
<filename>../../ext/amrnb/.libs/libgstamrnb.so</filename>
<basename>libgstamrnb.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>unknown</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Adaptive Multi-Rate Wide-Band Decoder</description>
<filename>../../ext/amrwbdec/.libs/libgstamrwbdec.so</filename>
<basename>libgstamrwbdec.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>unknown</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Demuxes and muxes audio and video in Microsofts ASF format</description>
<filename>../../gst/asfdemux/.libs/libgstasf.so</filename>
<basename>libgstasf.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>LGPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Read audio from audio CDs</description>
<filename>../../ext/cdio/.libs/libgstcdio.so</filename>
<basename>libgstcdio.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>GPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Decode DVD LPCM frames into standard PCM</description>
<filename>../../gst/dvdlpcmdec/.libs/libgstdvdlpcmdec.so</filename>
<basename>libgstdvdlpcmdec.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>LGPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Access a DVD with dvdread</description>
<filename>../../ext/dvdread/.libs/libgstdvdread.so</filename>
<basename>libgstdvdread.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>GPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>DVD subtitle parser and decoder</description>
<filename>../../gst/dvdsub/.libs/libgstdvdsub.so</filename>
<basename>libgstdvdsub.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>LGPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Encode MP3s with LAME</description>
<filename>../../ext/lame/.libs/libgstlame.so</filename>
<basename>libgstlame.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>LGPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>mp3 decoding based on the mad library</description>
<filename>../../ext/mad/.libs/libgstmad.so</filename>
<basename>libgstmad.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>GPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>LibMpeg2 decoder</description>
<filename>../../ext/mpeg2dec/.libs/libgstmpeg2dec.so</filename>
<basename>libgstmpeg2dec.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>GPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>mp3 decoding based on the mpg123 library</description>
<filename>../../ext/mpg123/.libs/libgstmpg123.so</filename>
<basename>libgstmpg123.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>LGPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>RealMedia support plugins</description>
<filename>../../gst/realmedia/.libs/libgstrmdemux.so</filename>
<basename>libgstrmdemux.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>LGPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Uses libsidplay to decode .sid files</description>
<filename>../../ext/sidplay/.libs/libgstsid.so</filename>
<basename>libgstsid.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>GPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>Encode MP2s with TwoLAME</description>
<filename>../../ext/twolame/.libs/libgsttwolame.so</filename>
<basename>libgsttwolame.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>LGPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
......@@ -3,7 +3,7 @@
<description>libx264-based H264 plugins</description>
<filename>../../ext/x264/.libs/libgstx264.so</filename>
<basename>libgstx264.so</basename>
<version>1.9.90</version>
<version>1.10.0</version>
<license>GPL</license>
<source>gst-plugins-ugly</source>
<package>GStreamer Ugly Plug-ins source release</package>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment