Commit 2b0ab6b4 authored by Steve Langasek's avatar Steve Langasek
Browse files

Drop maintainer scripts, only used for upgrades from natty and earlier

and no longer relevant post-precise.
parent bd20bb31
......@@ -2,6 +2,8 @@ mountall (2.37) UNRELEASED; urgency=low
* Document the branch location with Vcs-Bzr.
* Mark myself as maintainer, with Scott and James as uploaders.
* Drop maintainer scripts, only used for upgrades from natty and earlier
and no longer relevant post-precise.
-- Steve Langasek <steve.langasek@ubuntu.com> Fri, 18 May 2012 22:38:55 -0700
......
#!/bin/sh
set -e
dpkg-maintscript-helper rm_conffile /etc/init/mounted-varrun.conf 2.28 -- "$@"
#DEBHELPER#
#!/bin/sh
set -e
dpkg-maintscript-helper rm_conffile /etc/init/mounted-varrun.conf 2.28 -- "$@"
#DEBHELPER#
#!/bin/sh
# preinst script for mountall
#
# see: dh_installdeb(1)
set -e
# summary of how this script can be called:
# * <new-preinst> `install'
# * <new-preinst> `install' <old-version>
# * <new-preinst> `upgrade' <old-version>
# * <old-preinst> `abort-upgrade' <new-version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
dpkg-maintscript-helper rm_conffile /etc/init/mounted-varrun.conf 2.28 -- "$@"
case "$1" in
install|upgrade)
if dpkg --compare-versions "$2" lt 2.17 && \
[ "$FAKECHROOT" != true ]; then
rm -f /dev/.udev/rules.d/root.rules
fi
;;
abort-upgrade)
;;
*)
echo "preinst called with unknown argument \`$1'" >&2
exit 1
;;
esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
#DEBHELPER#
exit 0
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment