Commit 0ff40742 authored by Keith Packard's avatar Keith Packard Committed by Adam Jackson

Require libdrm 2.4.89 or newer

Both autotools and meson build systems had complicated logic around
what version of libdrm to require for various options. Remove that and
just check for a new enough version to support all of the options
which need libdrm.
Signed-off-by: Keith Packard's avatarKeith Packard <keithp@keithp.com>
Reviewed-by: Adam Jackson's avatarAdam Jackson <ajax@redhat.com>
parent 43ffd572
......@@ -1281,12 +1281,7 @@ AM_CONDITIONAL(DRI3, test "x$DRI3" = xyes)
if test "x$DRI" = xyes || test "x$DRI2" = xyes || test "x$DRI3" = xyes || test "x$CONFIG_UDEV_KMS" = xyes; then
if test "x$DRM" = xyes; then
AC_DEFINE(WITH_LIBDRM, 1, [Building with libdrm support])
if test "x$DRI2" = xyes; then
dnl 2.4.65 is required for drmGetDevice
PKG_CHECK_MODULES([LIBDRM], libdrm >= 2.4.65)
else
PKG_CHECK_MODULES([LIBDRM], $LIBDRM)
fi
PKG_CHECK_MODULES([LIBDRM], $LIBDRM)
fi
fi
......
......@@ -301,16 +301,8 @@ else
endif
libdrm_required = (get_option('dri1') == 'true') or (get_option('dri2') == 'true') or (get_option('dri3') == 'true')
libdrm_dep = dependency('libdrm', version: '>= 2.3.1', required: libdrm_required)
build_modesetting = false
if libdrm_dep.found()
if build_dri2
# 2.4.65 is required for drmGetDevice
dependency('libdrm', version: '>= 2.4.65')
endif
# 2.4.46 is required for cursor hotspot support.
build_modesetting = libdrm_dep.version().version_compare('>= 2.4.46')
endif
libdrm_dep = dependency('libdrm', version: '>= 2.4.89', required: libdrm_required)
build_modesetting = libdrm_dep.found()
build_vbe = false
if get_option('vbe') == 'auto'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment